GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: HID issues...

Hybrid View

  1. #1
    Sr. Mechanic 00chevy53's Avatar
    Join Date
    Apr 2010
    Location
    sebastian, florida
    Posts
    156

    Default HID issues...

    i was wondering if any one else has had any issues with there hids. im not sure if its the kit i bought or what but my lights will flicker and some times cut off completely if i go over a small bump or dip in the road. any ideas?
    2000 single cab short bed 1500 w/ 6.0 vortec maxx swap from a 2006 2500, custom intake, slotted brakes, shorty headers, 8mm wires, electric fan, strait piped, 4.5 inch lift, asp pulleys, true dual through body exhaust, built trans w/ shift kit, custom tune by efi alchemy...320rwhp

  2. #2
    Master Mechanic TritonBoulder47's Avatar
    Join Date
    Nov 2009
    Location
    Tunkhannock, PA (North East)
    Posts
    809

    Default

    Sounds like a bad electrical connection somethere... Also, make sure your ballast is mounted securely...

    Tim a.k.a. Da' Boulder

    2003 Chevrolet Avalanche Z71 - Custom Emergency Response POV

    Firefighter, Fire Policeman, Ambulance Driver, Rescue Tech, Emergency Lighting Installer

    Tint, 20's, Bull Bar, Intake, Exhaust, Billet Grill, Stereo, Custom Console, Emergency Equipment, and the list goes on...

  3. #3
    Sr. Mechanic 00chevy53's Avatar
    Join Date
    Apr 2010
    Location
    sebastian, florida
    Posts
    156

    Default

    thats what i cant figure out because everything i can physicaly do to secure them has been done...i even had the shop i got them from look at them and they couldnt find an issue... the only thing i can think of is the kit sucks, the kit i had on my last vehicle was made by another company and it diddnt require an alternate relay switch like this one it just conected directly to the stock wiring
    2000 single cab short bed 1500 w/ 6.0 vortec maxx swap from a 2006 2500, custom intake, slotted brakes, shorty headers, 8mm wires, electric fan, strait piped, 4.5 inch lift, asp pulleys, true dual through body exhaust, built trans w/ shift kit, custom tune by efi alchemy...320rwhp

  4. #4
    Legend Mean_Green_95's Avatar
    Join Date
    Apr 2009
    Location
    Baton Rouge, Louisiana, United States
    Posts
    1,170

    Default

    Possibly something inside the ballasts is loose or something. Try switching the ballasts out, get new ones from the shop you got them from if you have to.
    2010 Equinox LT
    2.4, 6 speed auto, power lift gate, remote start, bluetooth, xm.

    1995 Cheyenne C1500 ext. cab(my baby, my first truck)
    5.0, 5 speed, Silverado appearance package, power nothing, bucket seats and console Silverado, painted black interior, eBay halo headlights, eBay chrome tails, eBay cai, dual Flowmaster 40's w/no cats, 15x7 American Racing Hopsters, Walmart fog lights, SS mirrors

  5. #5
    Sr. Mechanic 00chevy53's Avatar
    Join Date
    Apr 2010
    Location
    sebastian, florida
    Posts
    156

    Default

    thats whats gonna piss me off... i havent had the kit for a year yet and there already messing up... i thinik its about $40 for each balast
    2000 single cab short bed 1500 w/ 6.0 vortec maxx swap from a 2006 2500, custom intake, slotted brakes, shorty headers, 8mm wires, electric fan, strait piped, 4.5 inch lift, asp pulleys, true dual through body exhaust, built trans w/ shift kit, custom tune by efi alchemy...320rwhp

  6. #6
    Master Mechanic TritonBoulder47's Avatar
    Join Date
    Nov 2009
    Location
    Tunkhannock, PA (North East)
    Posts
    809

    Default

    Your kit doesn't have any type of warranty...?

    Tim a.k.a. Da' Boulder

    2003 Chevrolet Avalanche Z71 - Custom Emergency Response POV

    Firefighter, Fire Policeman, Ambulance Driver, Rescue Tech, Emergency Lighting Installer

    Tint, 20's, Bull Bar, Intake, Exhaust, Billet Grill, Stereo, Custom Console, Emergency Equipment, and the list goes on...

  7. #7

    Default

    i have had 2 sets that had the same problem...i bought them both from the same guy...my lights have stopped flickering but my right side light only comes on when it wants to...i have to turn my lights on and off until it turns on

  8. #8
    Jr. Apprentice amily's Avatar
    Join Date
    Sep 2010
    Location
    Fremont, CA
    Posts
    21

    Default

    you can check the connection. maybe somewhere is loose...

    or switch the two ballasts on each side to check whether the ballast or bulb is defective.....
    live by heart...

  9. #9

    Default

    Quote Originally Posted by jml1022 View Post
    i have had 2 sets that had the same problem...i bought them both from the same guy...my lights have stopped flickering but my right side light only comes on when it wants to...i have to turn my lights on and off until it turns on
    This is the main problem I have with mine too. I switched the bulbs from one side to the other, and it is still the same side that I have issues with, so the problem is in my left side ballast. Based on what you said, I would suspect that for your right side ballast since I have the exact same symptoms.

    2001 Silverado Reg. Cab Not-So-Base -- SOLD
    2003 Avalanche Z71. No Cladding. Check out my Mod thread.
    1974 Triumph Spitfire 1500 - Work in Progress
    2003 Sierra 3500 Duramax. The Newer, Better Work Truck


  10. #10
    Jr. Apprentice amily's Avatar
    Join Date
    Sep 2010
    Location
    Fremont, CA
    Posts
    21

    Default

    maybe, two of his ballasts are defective....
    live by heart...

Page 1 of 2 12 LastLast

Similar Threads

  1. vss issues 92 k15
    By Snoopius in forum Chevy C/K Truck Forum
    Replies: 19
    Last Post: 10-08-2012, 12:38 PM
  2. two issues
    By HDCLINT7 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 09-17-2009, 05:24 PM
  3. Rim issues
    By Crakums_GT in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 06-17-2009, 11:21 PM
  4. ABS issues
    By hutch_pt in forum Lifted & Offroad Suspension
    Replies: 5
    Last Post: 05-10-2009, 03:36 PM
  5. ABS Issues?
    By Swatchvy in forum Lifted & Offroad Suspension
    Replies: 9
    Last Post: 03-10-2009, 05:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •