GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default 95 GMC Sonoma I4 idle prob

    Bought a proj truck for stepson. Buddy who sold it to me replaced a bunch of parts before finding the timing chain bad, once running good had rod knock. Truck came with a 97 S-10 I4 motor and trans. Stripped both motors and swapped all parts from the GMC to the S-10 long block including the intake (complete) and exh manifold(different flange...), all sensors except the crank sensor-there is a sensor on the S-10 that is not used (not present) on the GMC and is in the way to use the 90 degree GMC crank pos sensor so left the straight S-10 sensor.
    Truck started right up! Runs good and drives great but has a high idle. Am well versed in Mustang EFI but wanted some guidance on the GM stuff.
    Throttle plate is completly closed at idle and is sucking air through the hole in the top of the throttle body. It shuts off oddly-for lack of a better word-violently. In the last second when it is shut off, I can hear it sucking air violently and the motor shudders to a stop, but starts up fine.
    No CEL, but no GM scanner either! and no platesyet so can't take it to aparts store yet.
    Hand every vacuum line and checked for cracked and dryrotted hoses. We have not reinstalled te A/C, but I did mount the S-10 compressor so I could get the serpentine belt on, the GMC compressor has two electrical conectors as well at the clutch connector, not sure if the computer is seeing/not seeing a signal due these two conectors that go in the back of te compressof not being hooked up. Would appreciate any help possible.

  2. #2

    Default

    WELCOME HERE !!!

    Has nothing to do with the AC compressor...its only the psi switch for the compressor ( if low , wont work )

    I think it has to do with the crank sensor..maybe the ecm cant read the s10 sensor..IF I UNDERSTOD U CORRECT ?? not shure tho.

    hope somebody else can chime in !!

    1996 Suburban K3500 SLT DUALLY
    1988 Camaro RS 383 stroker LT1
    1992 32' Aero-tek Race Boat, 600 CI BBC
    WE CAN STICK A DIESEL IN ANYTHING
    SPECIALIZED IN CUSTOM CONVERSIONS OF ANY KIND
    Scott:glasses:

  3. #3
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    Welcome to the GM truck club
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


Similar Threads

  1. 03 Trailblazer a/c prob
    By markwebb30 in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 1
    Last Post: 06-19-2012, 06:13 PM
  2. Replies: 0
    Last Post: 01-10-2010, 10:20 AM
  3. need help! electrical prob
    By anorfolk in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 06-17-2009, 08:10 PM
  4. 350 carb prob. help
    By maw454 in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 03-07-2009, 07:31 PM
  5. heater control prob..help
    By mace in forum General Chevy & GM Tech Questions
    Replies: 7
    Last Post: 06-04-2008, 01:13 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •