GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default 2003 Suburban 4WD clicks when engaged

    I have a 2003 Suburban that clicks when the 4WD is engaged. I just put it in Auto 4WD and drove through a snowbank for fun. It thunked going into 4WD and continuously clicked when in 4WD. When in 4Hi it thunked while engaged and thunked on a regular basis while engaged.
    Any assistance will be appreciated.

    1986 Chevrolet Camaro Z28
    1999 Ford Explorer XLT
    2003 Chevrolet Suburban LT

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Sounds like a bad U-joint on the Front Driveshaft, or else the transfercase... id start with the U-joints on the front driveshaft however.. Also a CV axle can clunk to dpeending on how bad it is but it would have shown more signes before this.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    Someone hit the driver's side front bumper and fender while I was deployed. I'm afraid that the damage is not cosmetic, possibly only the CV joint.
    What do I look for the repair the u-joint / CV joint? I'm going to assume CV joint if the front tire was also hit. The front transfer case maybe suspect also?

    1986 Chevrolet Camaro Z28
    1999 Ford Explorer XLT
    2003 Chevrolet Suburban LT

  4. #4
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Well the CV joint should have a good boot on it and if not then right there that shows some of the issue. And for U-joints check for play in the driveshaft.. and the front differential is doubtful, the transfercase is the more common on the problems.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  5. #5

    Default

    I'm afraid for what may have gone wrong from being hit. Is there any way that the hub could have been damaged from the accident. I'm hoping for easy and cheap.

    1986 Chevrolet Camaro Z28
    1999 Ford Explorer XLT
    2003 Chevrolet Suburban LT

  6. #6

    Default

    I finally got under the truck. The connector to the motor that engages the 4wd had rubbed on the front drive shaft and almost wore through. I cut out the bad part and spliced the connection. It no longer thumps when engaging 4wd. It does, however make a thunk / popping noise once in a while when using 4wd. I used it in the lawn after repairing the bad wire (6" of snow should allow the truck to slip if needed). Any ideas what that noise could be?

    1986 Chevrolet Camaro Z28
    1999 Ford Explorer XLT
    2003 Chevrolet Suburban LT

  7. #7

    Default

    Could be a loose chain in the transfer case. if you start on a road that has some ice or snow on it and you hammer on the throttle and you hear this thunk/popping noise from somewhere below you then it could be the transfer case drive chain.

  8. #8

    Default

    Figured it out. The oil pump in the transfer case wore 2 small holes through the case. Required transfer case replacement to fix.

    1986 Chevrolet Camaro Z28
    1999 Ford Explorer XLT
    2003 Chevrolet Suburban LT

Similar Threads

  1. passenger rear brake light stays on when brakes arent engaged
    By jordanr1987 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 08-11-2011, 03:35 PM
  2. Chevy Volt color at mercy of clicks - Washington Times
    By Steve in forum Chevy Volt Forum
    Replies: 0
    Last Post: 11-20-2009, 12:11 AM
  3. PTO is ON, does this mean 4WD transfer case is engaged?
    By GlitchMobile in forum GM Powertrain
    Replies: 0
    Last Post: 11-17-2009, 08:31 PM
  4. G80 always engaged in 4x4 HELP
    By Madman in forum GM Powertrain
    Replies: 8
    Last Post: 08-16-2009, 10:47 PM
  5. 4 x 4 blows fuse when engaged
    By ghostracer in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 09-28-2008, 03:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •