GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default water temp gage not working, 99 tahoe

    on my 99 tahoe, the water temp gage just quit working, the needle will just go to the 1st line even when the engine is hot. how can I fix this ?

  2. #2

    Default

    Quote Originally Posted by loic View Post
    on my 99 tahoe, the water temp gage just quit working, the needle will just go to the 1st line even when the engine is hot. how can I fix this ?

    I would check......The Sending Unit and/or the Stepper Motor for the Water Temp Gauge.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3

    Default

    where are those located ?

  4. #4

    Default

    The sending unit is on the drivers side head. One lone wire coming down from the harness over the valve cover. There is a connector near the PCV valve. I believe the sending unit is between cylinders 1&3.

    Pretty easy to check the wiring and gauge. Remove the wire from the sender. The gauge should go all the way one direction, pretty sure it's to the cool side. Then touch the wire connector to the block or any other good ground. The needle should peg the other way. Assuming that all works properly, you can narrow the problem down to the sending unit, or thermostat.

    The thermostat is suspect if the gauge is moving at all. Do you have good heat in the cabin? If you let the engine warm up in the driveway, the gauge should come up to the 10 or 11 o'clock position, I forget the actual number LOL. If it goes way down once you start driving, the thermostat is your likely problem.
    When you hear hoofbeats, look for horses not zebras.

  5. #5

    Default

    ok, thanks,yes the heater is working fine. I'll try and check it tomorrow. thx for the infos !!!

Similar Threads

  1. overheating/coolent/water temp guage?
    By capt sensible in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 08-22-2010, 09:02 PM
  2. 96 s10 Fuel, Water Temp and Voltage Gauges dont work!
    By rx7srlife in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 0
    Last: 12-13-2009, 10:38 AM
  3. Help Putting in aftermarket water temp gauge
    By CJRM112 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 11-20-2009, 01:54 AM
  4. Water temp cycling high and low
    By Kraziken in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 07-26-2009, 09:50 AM
  5. Temp Guage Not Working
    By BIGFOOT in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 12-31-2008, 12:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •