GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default 06 Silverado-Weird Clunk When Accelerating

    Hi All,

    06 Silverado 1500 5.3

    When I accelerate from a stop, tranny shifts fine. If I give it a little extra gas, or hit the gas hard, I'm getting a clunk and it sounds like something under the passenger cab of the vehicle. The truck shifts smooth, does not slip and runs great. Only annoying thing is this clunk that sounds like my truck body is going to fly off the frame!!!!! I do not feel anything in the steering column. Any thoughts?

  2. #2

    Default

    U-joint maybe broken motor or trans mount hard to tell without hearing the noise!!!

  3. #3

    Default

    Sounds like a tranny mount to me bro

  4. #4
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,353

    Default

    Could also be a Body mount....I have broken them in the past..
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  5. #5

    Default

    Thanks all for the replies. I contacted a mechanic today and described what's going on. Within about 30 seconds he said "yoke" to me. Advised its a common problem in the Silverados. Quoting 200 for the part and 125 for labor.

  6. #6

    Default

    Just got back from the dealership. The Slip Yoke needed to be lubed. It corrected the issues.

  7. #7
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    Cool, that was an easy fix. Not too expensive either. Thanks for keeping us updated..
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


Similar Threads

  1. 2001 Silverado 1500 Z71 5.3L... Running weird.
    By jdusmc214 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 12-01-2010, 12:19 PM
  2. Clunk while accelerating after being parked
    By toughwaters in forum GM Powertrain
    Replies: 0
    Last: 10-24-2010, 10:40 AM
  3. 93 Silverado weird electrical gremlin. help!!
    By rustyironhead in forum GM Electrical Tech
    Replies: 4
    Last: 12-30-2009, 07:35 PM
  4. 02 Silverado acting weird.
    By USAFZ71 in forum GM Powertrain
    Replies: 2
    Last: 12-15-2009, 09:34 PM
  5. Weird Issue with 07 Silverado
    By ctruhn in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 9
    Last: 07-02-2007, 11:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •