GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 1998 suburban shift problem

    I'm new to the forum and would like to thank everyone up front for whatever suggestions you all come up with. The problem is the transmission will not shift up to 4th gear. The trans works perfect until it goes about 15-20 minutes then the rpm climbs and it reverts to like 3rd gear. The shift solenoids have both been replaced-The fluid was like new and no filings or sediments wer noticed. The computer has been replaced-reflashed for the vin #.
    The wiring is being checked as we speak. The connections I have been told are notorious for going bad. The truck has 142k miles on it and I love the way it drives etc. I hate to spend the money on another trans if this is not the answer. It always shifted perfect and the 4 wheel drive worked perfect until this happened. It's like a limp mode.
    Any help would be greatly appreciated as the Mechanic has had it for 6 weeks now with no end in site. I know I should bring it to another mechanic but I'm so vested now I need to perserver. Deke MacPherson

  2. #2

    Default

    You definitely need to take it to another mechanic. Unless the current mechanic is going to refund you for all the work done that didn't fix the problem, you are not "vested"
    When you hear hoofbeats, look for horses not zebras.

  3. #3
    Legend Bigbomber's Avatar
    Join Date
    Feb 2010
    Location
    Winnipeg,Manitoba,Canada
    Posts
    5,089

    Default

    X2!.......
    [/SIGPIC]2009 Chevy Silverado LT 1500 EXT CAB 4X4 Vortec 4.8L SFI,K&N air filter,Weathertech Floor Liners ,Weathertech Stone/Bug Deflector, Line X Spray On Bedliner, TruXport Rollup Tonneau Cover, Molded Mudguards, Viper 5701 LE 2 way Security Alarm/Remote Starter, Xm Satelite Radio,BILSTEIN 5100 rear shocks,BILSTEIN 5100 front levelling shocks,READYLIFT 2" rear lift blocks,Goodyear Wrangler Territorys -265/70R 17"

  4. #4
    Master Mechanic TexasEdition's Avatar
    Join Date
    Dec 2010
    Location
    Texas Hill Country
    Posts
    656

    Default

    Are you sure it has the correct fluid in the tranny?

    2009 Tahoe LTZ (Blue Granite ext/
    light & dark cashmere int)
    5.3L Vortec V8 6 speed trans.,
    HD towing, Leather interior,
    20" chrome wheels, chrome door
    handles/grill/mirrors, & CD/DVD w/Bose.
    2010 Silverado LT Texas Edition
    (Black ext/Light titanium-ebony int.)
    5.3L V8, 6 speed trans, HD towing,
    20" chrome wheels, chrome door
    handles/grill/mirrors, CD, Raptor 5"
    Magnum nerfs, & Speedliner bed liner.

  5. #5

    Default

    Welcome to the G M T C ! If you don't get enough info' with this post, try the other forums for maint. questions.


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

Similar Threads

  1. intermittent shift problem
    By A5150 in forum Chevy Truck Tech Forum
    Replies: 2
    Last: 01-03-2010, 02:52 PM
  2. 92 shift problem
    By blackdog62 in forum GM Powertrain
    Replies: 0
    Last: 12-15-2009, 09:01 AM
  3. Replies: 1
    Last: 12-15-2009, 08:31 AM
  4. 1998 6.5 GMC C3500 HD Hot start problem
    By Lou19 in forum Member Introductions
    Replies: 6
    Last: 09-28-2009, 10:02 PM
  5. trans shift problem
    By cokejim in forum GM Powertrain
    Replies: 0
    Last: 12-30-2007, 03:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •