GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: 85 Silverado

  1. #11

    Default 85 Silverado

    All,

    The sad news is that the vacuum advance was working but the mechanicaL ADVANCE was not. No need for stupid backpressure.

    Second, Due to mechanical puel pump installed and elctric fuel pump plumbed through this....and you have got to see where I am going with this...motor started making a nocking noise because fuel pump rod was pushed into cam and ruined the f*(&^%&& motor.

    Now i have to pull the motor and this time i will put it together. Took mechanical fuel pump off and the rod is stuck in the shaft and there is no way it will comeout. locked up or wedged in there.

  2. #12
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    The fuel pump rod is probably mushroomed over on the cam end & is now too large to slide out of the hole. It's possible this cam did not even have the fuel pump lobe on it to drive the fuel pump rod & it was actually riding on the cast base instead.
    If there isn't any metal circulating in the oil from this, you can take the mechanical pump off, block the mount with a block off plate & just leave the rod in there. It won't hurt anything because without the spring tension of the fuel pump arm spring, it will no longer be riding on the cam.
    Glad you found your distributor problem. Not having any mechanical advance will really make these run like dogs.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  3. #13

    Default

    wow that's crappy. Yeah never need both mechanical and electric, sorry you found out the hard way. x2 on what Stephan said, drain your oil and check it good, if there are no bits in it put fresh in and give it a shot. If you're really worried about it though best way is to pull out and start over again, which sucks.
    1986 Chevy G20 Tow Rig - 5.7 TBI conversion
    1978 Mustang II King Cobra Road Racer - Holley 650, MSD 6AL, 5 speed, 10 point Roll Cage, 9" posi, fuel cell, custom interior.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •