GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 11
  1. #1

    Default Subwoofers not working like they should

    Ok guys I'm almost to the breaking point with my subwoofers and or amp. Subwoofers have been working fine for little over a year , and amp has been working fine for almost 6 months on this set up. However the amp is a older kicker amp. So my set up has been 3 kicker DVC L5's on a 1200.1 kicker amp as I said it was all working great together for about 6 months when all of a sudden one day I turn it up a little, sounds decent at low volume then when I turned it up it was like the door speakers were the ones trying to push out all the bass, and door speakers started to distort. The door speakers are not hooked up to any amp at all. I checked the amp and noticed the fan on the amp was not working at all, the amp also does not go into protect just not very loud. Like I said I have run out of ideas so any help would be GREAT!! Thanks
    2004 chevy tahoe 35% tint on front windows, 5% tint on the back half ,flowmaster exhaust dumped, Spectre 9900 CAI, 3 12 inch kicker L5's, in-dash DVD/Navigation,kicker 1200.1 amp, removed cargo rack, black headlights lense, black turn signal lense, smoked tail lights, 8000K HID lights.

  2. #2

    Default

    You might what to check and see what frequencys you are sending to the subs. The amp should have an adjustment as well as the headunit. It sounds like your headunit is trying to send to many of the lower frequencys through your mids instead of the subs. Hope this helps

    -JJ
    04 Silverado Ext-Cab 2wd LS w/ 5.3L
    Spectre Performance CAI
    FLOPRO Dual Exhaust
    Bakflip HD Bedcover
    2005 Z71 17in wheels on Duellar A/Ts
    DDM Tuning 6k HID Low Beams
    Sony Headunit w/ iPod
    Blacked out Bowtie and Windows
    Matched Paint for bumpers and grill

  3. #3

    Default

    Thanks for the response, I will try it this weekend, what frequency do you think I should set the amp on? What frequency should I set on the headunit? Don't know if this has anything to do with what's going on but my RCA wire was giving me some problems because they are very old(4 or 5years old) and cheap. Would getting better RCA's fix this?

  4. #4

    Default

    Actually if I remember right I was having that problem too one time and had to get new RCA wires. Actually I was impatient and made my own but that will cause you major problems. But I also agree about the frequency. Your frequency should really be turned almost all the way down or towards the lowest frequency since you just have subs hooked up to your amp. If none of this works I would try a new amp.

    2006 Duramax LBZ
    Edge Evo
    4'' Diamond eye to 6'' tip
    16'' ion alloy, 33'' fierce attitudes
    Lots of work left to do!

  5. #5

    Default

    Anyone else have any other ideas?

  6. #6
    Master Mechanic TexasEdition's Avatar
    Join Date
    Dec 2010
    Location
    Texas Hill Country
    Posts
    656

    Default

    Any chance you changed the settings on your stereo when you thought you were just turning up the volume? Have you tried re-balance your stereo's bass and your amp to the subwoofer's bass? Here's a link:

    http://www.crutchfield.com/S-GaAES94...rs/tuning.html

    2009 Tahoe LTZ (Blue Granite ext/
    light & dark cashmere int)
    5.3L Vortec V8 6 speed trans.,
    HD towing, Leather interior,
    20" chrome wheels, chrome door
    handles/grill/mirrors, & CD/DVD w/Bose.
    2010 Silverado LT Texas Edition
    (Black ext/Light titanium-ebony int.)
    5.3L V8, 6 speed trans, HD towing,
    20" chrome wheels, chrome door
    handles/grill/mirrors, CD, Raptor 5"
    Magnum nerfs, & Speedliner bed liner.

  7. #7

    Default

    I would have to say some setting on the amp got changed.

  8. #8

    Default

    Quote Originally Posted by Kickerking817 View Post
    Ok guys I'm almost to the breaking point with my subwoofers and or amp. Subwoofers have been working fine for little over a year , and amp has been working fine for almost 6 months on this set up. However the amp is a older kicker amp. So my set up has been 3 kicker DVC L5's on a 1200.1 kicker amp as I said it was all working great together for about 6 months when all of a sudden one day I turn it up a little, sounds decent at low volume then when I turned it up it was like the door speakers were the ones trying to push out all the bass, and door speakers started to distort. The door speakers are not hooked up to any amp at all. I checked the amp and noticed the fan on the amp was not working at all, the amp also does not go into protect just not very loud. Like I said I have run out of ideas so any help would be GREAT!! Thanks
    You should be able to turn the subs off through your head unit - then you can play your other speakers to see how they sound. If they still distort maybe they are blown or they have to much of the "lows" adjusted to them?

    Are these the stock door speakers running off the head unit?

    If they worked before and all of the sudden you have problems - something changed - either adjustments made via the head unit, something else installed around the time the stopped working correctly or equiptment failure.

  9. #9

    Default

    The door speakers are kicker door speakers, I will try and mess with the settings later and see what happens. Thanks

  10. #10
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    You can always get bass blockers too for the door speakers, if your amp fan doesnt want to run then I would say something fried on the amp.
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Subwoofers - what do u have and what do u think
    By kburb in forum Audio, Video & Gadget Tech
    Replies: 12
    Last: 05-22-2010, 12:19 PM
  2. Subwoofers for sale.
    By 03 Black Sunshine in forum Audio & Video Classifieds
    Replies: 5
    Last: 11-11-2009, 06:48 PM
  3. Subwoofers
    By Burden33 in forum Audio, Video & Gadget Tech
    Replies: 11
    Last: 05-22-2009, 09:02 AM
  4. Subwoofers
    By A1CMason in forum Audio, Video & Gadget Tech
    Replies: 10
    Last: 04-28-2009, 03:17 AM
  5. Subwoofers
    By cheffernan in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 6
    Last: 06-08-2006, 04:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •