GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Jr. Apprentice
    Join Date
    Jan 2011
    Location
    North Carolina
    Posts
    16

    Question The Dreaded P0420 code ...

    Hey y'all. I stumbled upon this site and I have to say, great job. I'm pretty excited to be able to bounce around ideas in here!

    Now... I drive a 2000 Chevrolet Silverado 1500 with a 5.3. I'm at 160,000 miles and the truck is running like a champ, gas mileage is great (or as great as it ever was) and I really can't complain. About few months ago I was driving from NC to GA and the SES light came on. I stopped by the closest Autozone to make sure it was ok to keep driving and got the P0420 code... The truck was running fine, so I continued to GA, took it to a local shop and had them put it on their computer. It was showing that it was lean on banks 1 and 2. Long story short, we changed the fuel filter, reset the code, and voila... No more P0420... Until about 1,000 miles later. This time it only showed being lean on bank 1. I changed my gas cap, reset it, and about 300 miles later it came back on... So...

    I realize I tried some pretty inexpensive band aids for what is likely a larger problem (like the cats...) but I thought I'd run it by some of y'all and see what you think. It just seemed unlikely that both banks would show lean simultaneously, then not trip the code for so long??

    Any ideas would be much appreciated. I just can't drop $1500 bucks or so into a truck with 160,000 miles right now... That being said, I love my truck!!

    Too bad I'm in NC and not GA... Dadgum inspection... I figure it's a Silverado, not a Prius... I'm leaving a nice carbon footprint cats or no cats!

  2. #2

    Default

    Quote Originally Posted by ajwade View Post
    Hey y'all. I stumbled upon this site and I have to say, great job. I'm pretty excited to be able to bounce around ideas in here!

    Now... I drive a 2000 Chevrolet Silverado 1500 with a 5.3. I'm at 160,000 miles and the truck is running like a champ, gas mileage is great (or as great as it ever was) and I really can't complain. About few months ago I was driving from NC to GA and the SES light came on. I stopped by the closest Autozone to make sure it was ok to keep driving and got the P0420 code... The truck was running fine, so I continued to GA, took it to a local shop and had them put it on their computer. It was showing that it was lean on banks 1 and 2. Long story short, we changed the fuel filter, reset the code, and voila... No more P0420... Until about 1,000 miles later. This time it only showed being lean on bank 1. I changed my gas cap, reset it, and about 300 miles later it came back on... So...

    I realize I tried some pretty inexpensive band aids for what is likely a larger problem (like the cats...) but I thought I'd run it by some of y'all and see what you think. It just seemed unlikely that both banks would show lean simultaneously, then not trip the code for so long??

    Any ideas would be much appreciated. I just can't drop $1500 bucks or so into a truck with 160,000 miles right now... That being said, I love my truck!!

    Too bad I'm in NC and not GA... Dadgum inspection... I figure it's a Silverado, not a Prius... I'm leaving a nice carbon footprint cats or no cats!

    Trouble Code P0420 may mean that one or more of the following has happened:

    • Leaded fuel was used where unleaded was called for
    • An oxygen sensor is not reading (functioning) properly
    • The engine coolant temperature sensor is not working properly
    • Damaged or leaking exhaust manifold / catalytic converter / exhaust pipe
    • Retarded spark timing
    • The oxygen sensors in front and behind the converter are reporting too similar of readings

    Possible Solutions

    Some suggested steps for Troubleshooting a P0420 error code include:

    • Check for exhaust leaks at the manifold, pipes, catalytic converter. Repair as required.
    • Use a scope to diagnose the oxygen sensor operation (Tip: The oxygen sensor in front of the catalytic converter normally has a fluctuating waveform. The waveform of the sensor behind the converter should be more steady).
    • Inspect the downstream heated oxygen sensor (HO2), replace if necessary
    • Replace the catalytic converter

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3

    Default

    X2 what 99'Heartbeat said...but FWIW, i did all that too, and still had to replace the CATs...i'm in california, so i think my cats may be more expensive than every where else (damn cali emissions)...but very good troubleshooting technique...

    good luck!
    Mike - SoCal

    07 Sierra 1500HD
    Ultra Mammoth Wheels 17x8
    Nitto Terra Grapplers - 305/70/17
    Line-X Bedliner and Wheel Wells
    NFab Nerf bars
    CST 4" Spindle lift


    08 Hybrid Tahoe - wifey's ride
    McGaughy's 2/3 drop kit
    22x9.5 Tyfun Wheels
    Nexen Roadians 285/45/22

  4. #4

    Default

    Hey instead of losing money just cut the cats out and sell them! Do they really inspect for cats in NC??

    2006 Duramax LBZ
    Edge Evo
    4'' Diamond eye to 6'' tip
    16'' ion alloy, 33'' fierce attitudes
    Lots of work left to do!

  5. #5

    Default

    Welcome to the club.

  6. #6
    Jr. Apprentice
    Join Date
    Jan 2011
    Location
    North Carolina
    Posts
    16

    Default

    Thanks boys... Unfortunately, they certainly do inspect cats in NC... Dadgum police state...

    The thing that is throwing me is how I had no code, then a code for both cats, changed a fuel filter, and no code... Seems odd that both cats would go out simultaneously. Kind of like both your headlights going out at the same time... It ain't the bulb.

    I do have the infamous "cold tick" as well that is attributed to carbon build up... Think there could be a correlation?

    Or you think I'm just not dealing with the reality that Ole White Lightnin' is getting old?

  7. #7
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    Quote Originally Posted by ajwade View Post

    The thing that is throwing me is how I had no code, then a code for both cats, changed a fuel filter, and no code... Seems odd that both cats would go out simultaneously
    I think orriginally when you had "lean on both banks 1 & 2" it was just a plugged fuel filter rather than 2 bad cats, since replacing the F F fixed it for 1,000 miles before it threw any more codes. For your current prob I would follow Heartbeats & Cadis diag. & swap the sensors. If the prob follows the sensor then the sensor is bad. If the problem stays put after the swap then it would indicate 1 bad cat on that side, but you could still have the exhaust leak so you should check for that first before spending money for the cat.

    If you do have to replace the cat, don't let the shop keep the old one. Like Nutbush says those things are worth money & you can sell it to a scrapper. They buy them for the platinum.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  8. #8
    Jr. Apprentice
    Join Date
    Jan 2011
    Location
    North Carolina
    Posts
    16

    Default

    I appreciate all the help fellas... I'm going to do some "experimenting" this weekend. I'll definitely keep y'all posted. In the event that I do need cats, Caddiac, you have a link to where you purchased yours?

  9. #9
    Jr. Apprentice
    Join Date
    Jan 2011
    Location
    North Carolina
    Posts
    16

    Default

    Alright boys... I need some help understanding some numbers. I could "Google around", but I figure you boys are a trustworthy crew.

    I hooked up to an OBDII scan reader today and got this freeze frame data:

    P0420 (lean bank 1)
    STFT B1(%) 3.93
    LTFT B1(%) 21.88
    STFT B2(%) 2.34
    LTFT B2(%) 21.88
    MAP(kPa) 39.00
    Engine RPM 526
    Veh Speed 0
    MAF(g/s) 4.55
    TPS(%) 0.00

    I have a general understanding of some of that data. I do know that STFT bascially means the short term adjustments and LTFT is long term... Clearly my discrepancy is between STFT on bank 1 and STFT on bank 2... I was under the assumption that you were shooting for plus or minus 25 for a combined STFT and LTFT with a normally functioning cat. So my bank 1 combo would be 25.81 and my bank 2 would be 24.22... Seems like a ball park to me????

    Don't you miss the good ole days when we just climbed into the engine compartment of our trucks with a cold beer, a ratchet ,and a grin????

    I appreciate all y'all's help.

  10. #10
    Jr. Apprentice
    Join Date
    Jan 2011
    Location
    North Carolina
    Posts
    16

    Default

    Just as an update... After clearing the code, running a tank of 93 octane, and driving 100 miles, the SES light came back on as expected. This time, all the numbers were the same, except the STFT on bank 1... It was 0.00% and STFT on bank 2 which was -1.56.

    Any insight? I'm going to switch the back 02 sensors tomorrow and see what happens.

    As an interesting note though... I've noticed that the SES light only triggers when I'm stopped, maybe even when I have the wheel slightly turned. (It tripped today when I was pulling in my driveway to get the mail...) Could a loose vacuum hose on the power steering pump be possible?
    Last edited by ajwade; 01-30-2011 at 11:10 AM.

Page 1 of 2 12 LastLast

Similar Threads

  1. P0420 Code Fixes
    By 99burbman in forum General Chevy & GM Tech Questions
    Replies: 11
    Last Post: 02-25-2011, 02:59 PM
  2. P0420 Questions
    By craig82 in forum GM Powertrain
    Replies: 1
    Last Post: 01-27-2011, 07:56 AM
  3. P0420 Code Fixes
    By 99burbman in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 01-27-2011, 07:49 AM
  4. The dreaded fruit punch stain....
    By chevygurl in forum General Chevy & GM Tech Questions
    Replies: 19
    Last Post: 03-11-2010, 09:50 PM
  5. the dreaded code
    By chew246214 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 12-13-2009, 09:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •