GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 7 of 7 FirstFirst ... 567
Results 61 to 66 of 66
  1. #61

    Default

    Well, I have been dealing with this issue for over a year now, and I think I may have actually fixed it! I am still a little tentative about it, but considering I haven't been able to start it hot since late June, I think I may have finally tracked it down. Whenever it wouldn't start, I couldn't hear the fuel pump prime, so I was thinking it was the pump (it seemed to do it worse below 1/4 tank). Figured I would take the cheap route first, so I bought a new fuel pump relay from Napa. Cost me $18. Went out after I bought the relay, and it wouldn't start. Swapped the relays (took all of 90 seconds) and it fired right up. Has started every time since.
    Jess

    1991 Suburban


  2. #62

    Default

    I finally found my problem...I rebuilt the TBI and it now runs like a champ! I'm sure all the changed parts don't hurt either! LOL. Thanks for all of your help guys!

  3. #63

    Default

    Ok so it runs great but I'm still having trouble with it starting on its own without the help of starter fluid. Can anyone chime in here please. it runs great once I get it going but every time it needs starter fluid to start it up.

  4. #64

    Default

    I replaced the fuel pump relay in my Sub early September of last year. It was an easy replacement and cheap too (about $20). I have not had a starting issue since. Good luck with this.

  5. #65

    Default

    I've also changed my relay but still having the problem...IDK what to do next.

  6. #66

    Default

    I don't have time to read back, but I had problems with mine doing the same thing. I reseated the 4 pin connector on the distributor, and that got it going. Just make sure your connections are good and don't have any corrosion.
    1986 Chevy G20 Tow Rig - 5.7 TBI conversion
    1978 Mustang II King Cobra Road Racer - Holley 650, MSD 6AL, 5 speed, 10 point Roll Cage, 9" posi, fuel cell, custom interior.

Page 7 of 7 FirstFirst ... 567

Similar Threads

  1. 2007 Suburban Issues
    By bjordan72 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 12-07-2010, 10:14 PM
  2. 96 Suburban Issues
    By Magnum0016 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 08-21-2010, 10:18 AM
  3. Suburban issues!
    By artlock in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 07-30-2009, 02:38 PM
  4. '97 Suburban A/C Issues
    By KonaBurb in forum Chevy SUV & Crossover Tech Forum
    Replies: 1
    Last: 10-30-2008, 10:12 PM
  5. 99 Suburban Issues
    By ljjcsauto in forum GM Powertrain
    Replies: 4
    Last: 05-31-2008, 07:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •