GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default both low beams out at the same time?

    i cant find a fuse and the bulbs seem to be okay . the highs still work. is there a relay?

  2. #2
    Master Mechanic TritonBoulder47's Avatar
    Join Date
    Nov 2009
    Location
    Tunkhannock, PA (North East)
    Posts
    809

    Default

    What year truck...? There should be a relay and a fuse for each set of lights. It's in the under hood fuse panel...

    Tim a.k.a. Da' Boulder

    2003 Chevrolet Avalanche Z71 - Custom Emergency Response POV

    Firefighter, Fire Policeman, Ambulance Driver, Rescue Tech, Emergency Lighting Installer

    Tint, 20's, Bull Bar, Intake, Exhaust, Billet Grill, Stereo, Custom Console, Emergency Equipment, and the list goes on...

  3. #3
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Yep more on the year, since i have had the multifunction switch act funny, and when you go to high beams it will stick, and when you try to switch back to lows they wont come on. Also the head light switch. But as mentioned start with relays etc.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  4. #4

    Default

    well its a 1990 k 1500 . uhm i cant seem to find a fuse . last night the low beams came back on . i have a spare headlight switch and it had no effect . so idk what it is unless there is a relay but i dont know where its located .

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    There isnt a relay.. it sounds like your Multifunction is shot.

  6. #6

    Default

    idk the weird thing is my plow lights are wired with my low beams. But when my low beams went out my plow lights still worked .

  7. #7
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    See you failed to mention that you have a plow. I cant really help you much there since ive never had a problem with lighting on a plow. But it does sound like you have a crossed wire etc..
    And alot of the plows that i have delt with and or driven have had it set up where the only lights that worked were the ones on the plow.

  8. #8

    Default

    well an update the switch that switches my headlights to the plow lights was going bad..

Similar Threads

  1. All on high/low beams?
    By minichip in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 01-18-2011, 10:51 AM
  2. 92 sierra low beams do not work high beams do??
    By id10t in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 01-02-2011, 12:31 AM
  3. no low beams
    By bessyblue in forum General Chevy & GM Tech Questions
    Replies: 9
    Last: 01-26-2009, 07:53 PM
  4. 2001 No Low Beams
    By jhaney68 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 01-11-2008, 05:24 PM
  5. How to keep fog light on with high beams
    By ejamin73 in forum GM Electrical Tech
    Replies: 3
    Last: 11-26-2007, 12:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •