GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 3 123 Last Post byLast Post by
Results 1 to 10 of 21
  1. #1

    Default major issues with 98 blazer 4x4 4.3

    i have a 98 blazer i live in alberta it dropped to -50 c about a week ago before everything was fine it overheated the freeze plug was going but now it keeps overheating not in any patern the catalytic converter burnt it was ash inside i straight piped it changed the thermostat and got a coolant flush it is still brown in some places i just did the head gasket test let it run to normal temp with rad cap off if it bubbles a bunch the head gasket is done for but there was no bubbles i hear it could be the water pump engine is running really sluggish power loss there is still compression i get codes p0300 p0101 and p0300 pending the straight pipe is not totally sealed i can see exhaust coming out of it but i am more worried about the overheating problem at the moment wife cant take it to work and she hates it now i love this truck and dont want to get rid of it somebody please help me
    Last edited by jrb_fishy; 02-07-2011 at 02:48 PM.

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    P300 is for random cyl misfire, and P0101 is for the Mass Air Flow sensor.
    It sounds like you may have fried the Intake gaskets. Also have you changed the T-stat when you did all of this? because if it is intermittent there is a chance it is sticking closed.
    But the P300 is and P101 is something you really need to look into.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3

    Default

    yes i did change the thermostat the overheating problem has been delt with and fixed it was the water pump now on the p0300 it has no cat converter anymore we just took it off the other code ended when i changed the water pump i am guessing that the o2 sensor is sending the signal to the ecm that there is a problem and it is changing the fuel air mixture and causing all these problems i am looking for an o2 sensor simulator to try and fix this issue but any other suggestions would be greatly welcome

  4. #4

    Default

    alright i am still having the overheating problem it is still loosing coolant can not figure out from where its somewhere on the bottom top and sides of moror are dry this is starting to piss me off

  5. #5
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Alright have you taken a look at the intake gaskets they will often leak in the back of the motor out of sight.

  6. #6

    Default

    i do know where it was straight piped it has a leak there but i think that it needs a o2 sensor simuator as well but that is not what i am so worried about its the damn coolant issue that is got me worried

  7. #7

    Default

    ok so i took the air intake off and the codes changed to a p0301 i checked the spark plug wire and it was messed up so i have all new wires i only have one on so far and it reads p0300 again remember there is no catalytic converter on there as for the coolant i put a new rad cap on there it overheated 3 times today in the morning and by overheated the coolant itself was boiling between the altinator and the ac pully there is a spot for what looks like a temprature sending unit plug the female end is there no male end i went and took the tsu from the drivers side above cylender 3 and pluged it into there and the temp holds at normal rad heats up again i even took the truck on the highway at 150 kph and no change in temp i drove threw town at 50 kph and bam the heat rose i pulled the truck over let it sit for maybe 5 mins and turned it back on with the res cap off it bibbled a bit and then the temp went back down to 3/4 i drove it and it went back to just bellow half where it always sits now from what i can tell this an air lock in the line or the coolant is not mixed right ps there is some stop leak in there but i plan on draining it and replacing the leak itself was the hidden overflow hose from the res but the problem is still very real and i need some help on this one

  8. #8

    Default

    still doing its overheating and coolant boiling thing along with the misfire and running rough but yesterday the gauge went right up and everything was cold upper rad hose rap itself and i was even able to stick my bare hand on the block i would guess temprature sending unit i want to get this all fixed and sell this thing its got an amazing body and after market rims with mudders but from the week i got it its been a pain in my ass starting to hate this truck wife already hates it lol

  9. #9

    Default

    alright things are getting weirder and weirder i just did a compression test it looked good but i had the batt fuse pulled and the distributor cap unplugged and it still started up lol this truck is the devil i tell you the devil

  10. #10

    Default

    so my codes are now
    1 P0300
    2 P0340
    3P0300 repeat
    i have checked almost everything here the wiring seems to all be good i put a new crankshaft sensor and maf sensor in just to be sure it still boils the coolant and runs like a bag of **** all the time when you clear the codes it runs better untell the codes come back in then its back to hell i dont know what else to do

Page 1 of 3 123 Last Post byLast Post by

Similar Threads

  1. Chevrolet : Blazer 4X4 BLAZER 1986 GMC 4X4 BLAZER SHOW TRUCK CHEVORLET
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 08-17-2010, 08:00 PM
  2. Chevrolet : Blazer 1990 Modified Chevy Silverado Blazer Monster Truck
    By ChevyFan in forum Chevy Trucks For Sale eBay
    Replies: 0
    Last: 07-17-2010, 11:10 AM
  3. Major Engine ISSUES!
    By BajaMark in forum GM Powertrain
    Replies: 5
    Last: 04-06-2010, 02:10 PM
  4. Replies: 0
    Last: 03-09-2010, 09:00 AM
  5. major electrical issues, stalling, flashing lights, cruise malfunctions.... help?
    By kawasaki_kid in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 05-20-2009, 07:10 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •