GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 2003 Instrument panel to LEDs!?!?!

    Need some advice from you guys , I just changed my instrument panel lights over to the Blue LED's like in reggiecab2000's thread , but my truck is a 2003 , so I had to de-solder 8 small lights and solder in my LED's. Everything went fine , looks great ,BUT....I have 2 out of 8 LED's that started blinking on and off! Connection is fine , and its not just blinking like a loose connection , its like Christmas lights! 3-4 seconds on then 2-3 seconds off! Anyone know what causes this? My new Stepper Motors will be arriving today , so I'm replacing them tomorrow ,just got to get these 2 lights to stop blinking!?!?! (It's the temp LED and the passenger side speedometer LED thats blinking)
    2003 Silverado Z71 Extended Cab 5.3L, K&N air filter , Flowmaster exhaust , Blacked -out Bowtie , leather interior , up-graded to 17's

  2. #2

    Default

    Where did you get the LEDs? They make LEDs with blinkers inside them. Did you get the polarity correct? Maybe it flashes one direction and is steady the other?

  3. #3

    Default

    I got the 194's from DTM motors in California , off of Ebay. They come in sets of 2 , all of the packs are the same , steady burning , but the 2 are flashing . When I turn them around they won't burn ,so I know their hooked in right.

  4. #4

    Default

    Forget this MESS!!!!......went to the salvage yard and got another cluster.....the new stepper motors were a PAIN! After replacing them , every gauge shot to the right -wide open and the speedometer quit........so I get to use my GLOCK on the old Cluster thie weekend.

  5. #5

    Default

    Quote Originally Posted by Bama Z71 View Post
    Forget this MESS!!!!......went to the salvage yard and got another cluster.....the new stepper motors were a PAIN! After replacing them , every gauge shot to the right -wide open and the speedometer quit........so I get to use my GLOCK on the old Cluster thie weekend.
    That's the spirit haha. I was actually going to attempt to replace the stepper motor on my fuel gauge in the near future but if its really that much of a hassle then I'll just stick to using the trip computer
    04 ECSB Custom silver & grey, Soft 8's, BFG KO's, ReadyLift Leveling Kit, Hellwig front sway bar, K&N filter, DeeZee EZ-Down, Rhino liner, Alpine CDE103BT, Rockford 6.5's, 12" V.A.T. Hammer Pro in a Subthump box, Alpine PowerPack amp, Hifonics amp, BackRack w/ 55w 5000k HID KC Daylighters, KC light bar with 4 KC Slimlites, UWS toolbox, Shaved Antenna mod, Black Bowtie, LED backup, license plate, dome lights & 3rd brake light


Similar Threads

  1. Instrument Panel Bulbs
    By Stonewall42 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 01-20-2010, 10:51 PM
  2. how many bulbs in the instrument panel?
    By 1995ChevyHoe in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last: 09-17-2009, 04:29 PM
  3. Where can I get Instrument Panel bulbs?
    By The Pawnbroker in forum Audio, Video & Gadget Tech
    Replies: 7
    Last: 10-14-2008, 10:19 PM
  4. Instrument panel lights went out
    By johncc in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 10-01-2008, 08:56 AM
  5. DOD Instrument panel indication
    By bfrench in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 0
    Last: 08-19-2007, 09:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •