GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 96 suburban losing power

    Hey guys im new to the forum but Ive been reading quite a bit. I have a 96 suburban and for the past few weeks it has felt sluggish. It doesnt throw any codes and it doesnt really hesitate or miss that i can tell. It just feels like I am pulling a trailer or something. Seems like i have to lean into the throttle more than usual. I do my own work but I just couldnt figure it out so I took it to the gmc dealer to have them diagnose it.
    They pressure checked one cat and it checked out fine but they were unable to check the other one because the o2 sensor was really frozen in there and they were afraid to break it. It is there opinion that my fuel pump is bad. The sheet that they gave me says "after priming fuel system could only achieve 57psi key on and engine off. spec is 60-66. for sequential fuel injection."
    My question is...could that little of pressure difference cause this problem? i would hate to drop the tank and find out that this is not the problem. Also as a side note, I have replaced the spider assembly a few months ago with the updated one. It ran great right after the upgrade.
    Thanks guys!!

  2. #2
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    Welcome to the club. It could be fuel pressure, could also be a plugged cat, but it could be a few other things too. How many miles are on this vehicle? How long since you've checked compression & tuned the engine? Also check your E brake cable & check to see if your rear brakes are getting hot. Sounds funny, but the way you describe it like "you're towing a trailer" is exactly what rear brakes dragging feels like when the cable is not releasing all the way.

    **Before I would let the shop fault the fuel pump, I would consider less expensive things like filter & sock.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  3. #3

    Default

    Thanks for the reply. The truck has 189k on it. I have not done a compression test but I recently changed plugs wires cap, etc. I will look into the brake line. Good idea. i was wondering about compression as well, but the problem has seemed pretty sudden.

    ---------- Post added at 04:01 PM ---------- Previous post was at 03:04 PM ----------

    Well the rear brakes dont seem to be binding up or anything. An now I have the dealership saying fuel pressure is too low and another mechanic saying that its not low enough to make a difference. Im so confused. lol

  4. #4
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    I agree with mech #2 that says that (3 psi out of specs) isn't low enough to cause it to be a dog.

    Even though you have now checked your brakes & they don't seem to be dragging cold, the best test now is to go drive it & see if they drag then. Do they get hot to the touch after 5 miles, 10 miles of driving? The problem with brakes is that when they drag a little, they heat up & expand & then drag more. This just perpetuates itself because the hotter they get the more they expand & the more they expand the more they drag & the hotter they get & it just goes on & on.

    As far as low compression causing a sudden problem... When a cylinder starts losing comp it isn't always noticeable untill it gets down to around the 95 -110 psi range where the fuel has a lot more trouble trying to fire off. I'm thinking more along the lines of bad spark plugs or wires etc. but checking the compression is key, because good compression is the basic foundation of a good running engine. I also forgot to mention before to check the air filter. A clogged AF will cut the power down.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  5. #5

    Default

    Wouldnt the ignition or bad compression cause the engine to miss and feel like its running rough? The engine is still smooth its just not peppy like it usually is. Also, I just put my own fuel pressure gauge on it and I got 50 psi with key on engine off and 50 with engine idling and it will spike up to almost 60 if i rev the throttle.

Similar Threads

  1. 96 Suburban losing power in over-drive
    By DeadHead in forum GM Powertrain
    Replies: 10
    Last Post: 08-15-2010, 05:09 PM
  2. losing power
    By pryormancan in forum Member Introductions
    Replies: 9
    Last Post: 07-05-2010, 03:03 PM
  3. why am I losing power when going up hills????
    By nyaristo in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 12
    Last Post: 02-23-2010, 09:41 PM
  4. Losing power
    By aggie99 in forum GM Powertrain
    Replies: 0
    Last Post: 09-24-2009, 01:02 PM
  5. error code H02S-11, truck stalling/losing power while driving
    By pulawman in forum General Chevy & GM Tech Questions
    Replies: 17
    Last Post: 03-30-2009, 08:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •