GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37
  1. #1
    Sr. Apprentice
    Join Date
    May 2007
    Location
    Lenexa, KS
    Posts
    42

    Default Module under seat?

    Alright boys and girls. I noticed a small box plugged into a harness under my seat. It's a Delco part, model 16152531 (serial 2071496). See picture below;



    I started the truck with the module in it's current location and also unplugged and there was no change. I've searched the web looking for performance parts, original parts, and used parts and haven't come up with anything. Does anyone know what this darn thing is and what it does??

    Any help would be appreciated, thanks!
    Last edited by 93BURB; 06-05-2007 at 07:26 PM.
    1993 Chevrolet Suburban
    K2500 4X4 w/ 7.4 L 454

  2. #2

    Default

    Flux capaciter. Only kicks in when your traveling through time.
    j/k
    Gotta look under my seat now to see if I have one.

  3. #3

    Default

    Yeah my flux capaciter was malfunctioning for a while. I could only go back in time it was terrible, although there was some great offroading during the creatacious period. I'll check too and see if i have one.
    Dan
    1999 GMC Sierra 2500 350 vortec
    1967 Jeep M725 ambulance 230 tornado
    1990 Cherokee Limited- 3 inch lift on 33's
    ...and every one of em has issues

    If you have any questions or problems don't hesitate to send me or any other GMTC moderators a PM

  4. #4

    Default

    Isn't that to do with power seat stuff or air bags or something like that?



    Jamie

    2007 Ford E250(Work van) (Ya, Ya, shut up!)
    1996 GMC Sierra SLE 1500 5.7L/4L60E

  5. #5

    Default

    Hey let me know if you 2 find anything good under there...Maybe a donut or 2?



    Jamie

    2007 Ford E250(Work van) (Ya, Ya, shut up!)
    1996 GMC Sierra SLE 1500 5.7L/4L60E

  6. #6
    Sr. Apprentice
    Join Date
    May 2007
    Location
    Lenexa, KS
    Posts
    42

    Default

    Quote Originally Posted by Cableguy View Post
    Isn't that to do with power seat stuff or air bags or something like that?
    My Burb doesn't have power seats....or air bags. Good thinking though!
    Last edited by 93BURB; 06-05-2007 at 08:19 PM.
    1993 Chevrolet Suburban
    K2500 4X4 w/ 7.4 L 454

  7. #7
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    I've got it too. I noticed it some time back, and thought it had to do with the seats.

    The mystery goes on.
    Maybe Fiero, or unplugged can solve this one for us.
    Patrick
    Rhode Island


  8. #8

    Default

    I've got one about under the drivers seat of my 96 4x4. My neighbors 95 2wd doesnt have one. Maybe something to do with the 4x4 and transfercase.

  9. #9
    Legend
    TrailLeadr's Avatar
    Join Date
    Jun 2005
    Location
    Coventry, Rhode Island
    Posts
    3,103

    Default

    Quote Originally Posted by tbplus10 View Post
    I've got one about under the drivers seat of my 96 4x4. My neighbors 95 2wd doesnt have one. Maybe something to do with the 4x4 and transfercase.
    Very possible. Now that this thread started, I was thinking maybe transmission controller.

    My transfer case is all manual, the only electronic part of it was the Thermal Linear Actuator(TLA) on the front axle, the switch to activate it, and the light to indicate 4X4.



    So the only thing that might control would be my 4L80E trans, not my 4x4. IMO
    Patrick
    Rhode Island


  10. #10
    Sr. Apprentice
    Join Date
    May 2007
    Location
    Lenexa, KS
    Posts
    42

    Default

    Quote Originally Posted by tbplus10 View Post
    I've got one about under the drivers seat of my 96 4x4. My neighbors 95 2wd doesnt have one. Maybe something to do with the 4x4 and transfercase.
    That's a good possibility as I didn't try to move the truck with the module unplugged... Anyone else have an opinion??
    1993 Chevrolet Suburban
    K2500 4X4 w/ 7.4 L 454

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Short in power seat, airbag, seat heater
    By petek1065 in forum GM Electrical Tech
    Replies: 2
    Last Post: 11-27-2009, 06:55 PM
  2. Removing RSA (Rear Seat Audio) Module...
    By inker in forum Audio, Video & Gadget Tech
    Replies: 1
    Last Post: 07-21-2009, 03:45 PM
  3. light control module or keyless entry module
    By fd8215 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 05-01-2009, 08:45 AM
  4. Heated seat module - easy fix?
    By Kraziken in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 10-12-2008, 11:45 PM
  5. Tahoe seat belt and back seat release cable
    By fishbizz in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last Post: 11-09-2007, 05:50 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •