GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3

Thread: still messed up

  1. #1
    Jr. Apprentice
    Join Date
    Feb 2011
    Location
    Long Beach Island,NewJersey
    Posts
    12

    Default still messed up

    here we go fellas. i hooked up my battery backwards in my 1990 gmc suburban .well i popped 2 fuses.ECMB and the ECM1 .i replaced the ECM1fue it stayed good ,i replaced the ECMB it popped again . 4 fuses later it stayed.now the prob is i dont have spark and my injectors wont fire.i have power to the coil and i have power to the injectors.no spark and injectors wont fire.i have a 89 so i took the computer out of it(same)i tried it in my 90,nothing.switched the chips from my 90 into the computer from the 89 ,nothing.i put the chips from the 89 in computer for my 90,nothing .changed the coil,changed the ignition module,changed the esc.nothing .everything works when i turn the key.or i would of tried the ignition switch.checked all fuseable links on both ends for power and ok.no burnt wires that i can find in any of the harnesses.seeems to have power evrywhere there should be .im running out of ideas of where to look.and what to test.the only thing i have tried to change yet is the distributor thinking maybe i fryd the pickup coil ,who knows.this has everyone that ive talked to stumped and clueless.hopefully you guys can help me .thanks!

  2. #2

    Default

    Did you check your GROUND WIRES on the block and also the wires on the Starter and alternator ????? just an idea !

    1996 Suburban K3500 SLT DUALLY
    1988 Camaro RS 383 stroker LT1
    1992 32' Aero-tek Race Boat, 600 CI BBC
    WE CAN STICK A DIESEL IN ANYTHING
    SPECIALIZED IN CUSTOM CONVERSIONS OF ANY KIND
    Scott:glasses:

  3. #3
    Jr. Apprentice
    Join Date
    Feb 2011
    Location
    Long Beach Island,NewJersey
    Posts
    12

    Default

    Yeah I've checked the power wires that go to starter. I've also checked the two main grounds. My last guess is that I may have fryd the pickup coil in the distributor . I've already changed the ignition module inside the distributor.

Similar Threads

  1. Messed up
    By brickborn in forum General Chevy & GM Tech Questions
    Replies: 20
    Last: 09-02-2011, 10:19 PM
  2. crankshaft threads messed up, PLEASE HELP!
    By Lifted_Bowtie in forum GM Powertrain
    Replies: 14
    Last: 01-14-2011, 05:33 AM
  3. Blower Fan Speed Messed Up!
    By agearhead2 in forum GM Electrical Tech
    Replies: 3
    Last: 12-03-2010, 07:34 PM
  4. What Part of my Tranny is Messed Up?
    By Crawdaddy in forum GM Powertrain
    Replies: 24
    Last: 05-19-2008, 07:46 AM
  5. Website Format Messed up
    By ChevyFan in forum Announcements & Feedback
    Replies: 4
    Last: 03-26-2008, 02:35 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •