GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7

Hybrid View

  1. #1

    Default need some Headlight help, having issue

    Just got into our 1999 GMC K1500 Sierra SLT and the headlights were off but the blue hi-beam indicator was on and buzzing. By buzzing I mean the same noise you hear warning you that you left your lights on while engine off/door open.

    I turned the lights on and the noise stopped but there are no headlights...high or low beams. No running lights but parking and turns work.

    Could it be fuses, relay...? Any suggestions would help for me to look at. We've been hit with another snow storm so I'm checking online to get good starting points before trying to screw around in the cold, with no garage and it getting dark outside. I just bought this truck couple weeks ago, last we used it was Tuesday to pull home our new camper. Everything worked fine then.


    I appreciate the help folks!

  2. #2

    Default

    sorry I cant help. but this will help keep it towards the top of the todays post page.
    David
    2004 Silverado 2500 Crew Cab 4x4, AMSOIL EA air filter, Granatelli MAF sensor, Throttle body spacer, Magnaflow exhaust (true dual to 2 in 1 out muffler), 6" ProComp lift (add a leaf and 5" superlift rear block), Bilstein shocks, 35's (Cooper Disoverer ST) and 4.10 gears, Rhino Liner, EGRUSA fender Flares and widow visors, extended stainless steel brake lines, firestone airbags w/onboard air compressor, Pioneer Avic X940BT navigation, Accel backup camera.
    http://www.gmtruckclub.com/forum/sho...Silverado-2500
    1960 Land Rover Series II 88
    2001 Pontiac Sunfire
    2013 Toyota Avalon Limited (Wife's Car)
    NRA Life Member

  3. #3

    Default

    ok... after checking fuses, relays and replacing the switch... still no headlights. Anyone?

  4. #4

    Default

    still looking for some help on this

  5. #5

    Default

    Not sure about the noise issue.

    However, the headlights maybe do to a bad switch.

    I had put a higher wattage set of lights in my truck, and have had to replace the switch several times.
    Pavement sucks... :grrrrrr:



    1994 K1500 4x4 Ext. Cab
    PCM chip and Xenon 8000k bulbs
    350cu.in bored over .050"
    balanced Crank, 10:1 compression
    Flat top pistons,cam,ported heads
    Option Racing Cold Air Intake
    Holley Throttle Body Spacer
    Accell Igition, 45kv coil
    FloTech Headers, no CATs, dual exhuast
    Goodyear Silent Armor A/T 305/70-16
    Pioneer SupertunerIII CD USB Bluetooth
    Kicker ZX200.2 ZX Amp
    Kicker Audio COMP 10" Subwoofer

  6. #6

    Default

    already tried two different switches... no luck

  7. #7

    Default issue resolved

    There was a short in the headlight wiring. $263 later and headlights are functioning normally.

Similar Threads

  1. Installing new HID's.....Headlight housing issue
    By Black & Tan in forum Chevy Truck Accessories
    Replies: 3
    Last: 11-08-2010, 06:58 PM
  2. Headlight/Highbeam and Foglight wiring issue
    By captrcpjr in forum GM Electrical Tech
    Replies: 2
    Last: 01-11-2010, 06:15 PM
  3. '99 Silverado headlight issue.
    By Sinner13 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last: 04-04-2009, 01:18 AM
  4. Headlight issue
    By Kraziken in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 03-02-2008, 09:07 PM
  5. headlight issue??
    By GM_Guy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 12-13-2007, 11:32 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •