GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Cold start problem

    I put a rebuilt quadrajet carb on last summer. Now that its getting pretty cold when I go to start the truck (84 k10 305motor) it only seems to run on a few cylinders then dies. I start it again and it will do the same thing. Then I have to floor it like it is flooded and it will start and run while I feather the gas pedal. then it will idle just fine. But if I try to put the truck in gear it dies. It will keep dying until it warms up enough. Is this a too rich condition? I havent had time to adjust the carb yet so I'm thinking of first setting the idle mixture screws and go from there.
    84 Chevy 1/2 ton Rathdrum ID

  2. #2

    Default

    Mine was doing that, too. Turned out to be the diaphragm in the vacuum choke pulloff wasn't working.

    On my carb, the choke shuts completely in the cold to give a rich start. When the motor starts, the vacuum in the manifold pulls the choke pulloff and opens the choke just enough not to kill it. Then as the choke warms up it opens up.

    Take off the air cleaner and see if the choke on the primary is completely shut. Then have someone start it and see if it opens any at all. If not, use a screwdriver to open it a bit. If you can keep it running by adjusting the choke opening with the screwdriver, it's probably that pulloff.

    In 20 degree weather it would take me 20 minutes to get it warmed up enough for the choke to open so I could drive. I hated it.

Similar Threads

  1. No Luck 2001 1500 cold start problem.
    By bill.turner3 in forum General Chevy & GM Tech Questions
    Replies: 18
    Last: 11-23-2010, 09:01 PM
  2. Remote Start Problem When Cold
    By dextertech in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 11-21-2010, 01:29 PM
  3. Cold Start
    By bballtilg15 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 12-09-2009, 04:35 PM
  4. 99 5.7 vortek cold start problem
    By captainb6 in forum General Chevy & GM Tech Questions
    Replies: 11
    Last: 09-07-2009, 07:01 AM
  5. TBI No cold start
    By FireRed in forum Performance & Fuel
    Replies: 0
    Last: 11-24-2008, 05:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •