GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default How To: Test TBI Distributor Signal/Injector Pulse

    Symptom: TBI has no injector pulse; distributor test

    Requires: Test Light with probe/clip.

    Unhook the 4 pin harness from the back of the distributor.
    Attach the clip of your test light to 12V Positive.
    Turn on the Ignition.
    Tap the purple/white wire on the 4 pin dist harness (IC Reference High) with the test light probe; it should create a test signal and fire the injectors.

    If this test is successful, reattach and try cranking. If still no injector pulse, check power feed to the distributor; if power feed is good, ignition module in distributor is bad.
    1986 Chevy G20 Tow Rig - 5.7 TBI conversion
    1978 Mustang II King Cobra Road Racer - Holley 650, MSD 6AL, 5 speed, 10 point Roll Cage, 9" posi, fuel cell, custom interior.

  2. #2

    Default

    My problem is similar to this post, perhaps you can help me? My car, C4 from 84, will crank but not fire up the injectors when cranking. I can start it with start spray or fuel being poured into the intake. It will keep running then and fine unitll switched off. Also able to drive then. But whenever the ignition key is switched to the off position.. No fuel from injectors when cranking again. I have checked the wire coming from the ignition (purple white) with the probe light like mentioned in your post.. No spray then.. Any other things for me to check? I am hopeless...

  3. #3

    Default

    Bump. Any chance we can get a sticky on this post? Every time I get on here, I see someone else with this problem, who apparently hasn't seen this post about testing.
    1986 Chevy G20 Tow Rig - 5.7 TBI conversion
    1978 Mustang II King Cobra Road Racer - Holley 650, MSD 6AL, 5 speed, 10 point Roll Cage, 9" posi, fuel cell, custom interior.

Similar Threads

  1. frankenstein van no injector pulse
    By dualdj1 in forum GM Powertrain
    Replies: 3
    Last Post: 12-02-2010, 01:04 PM
  2. 1990 305 no injector pulse
    By kcfocus1 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 09-02-2010, 10:30 PM
  3. Easy way to test DL3 signal mirrors?
    By cwaters425 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last Post: 02-11-2010, 03:10 PM
  4. Turn Signal problem.. doesn't pulse..
    By Falcone in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 10-29-2009, 11:20 AM
  5. How do I Test the Coil on the top of the distributor?
    By Holy Smoke in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 02-06-2008, 01:02 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •