GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 92 chevy no start instraments go haywire

    Ok so its a 92 Chevy pickumup truck. Just replaced the motor. And damned near everything else. When you turn the key to the on position everything works just fine. But once you turn the key to start the cluster panel goes ape**** and the starter just clicks. Good battery and starter. Pulled it off and had it tested. What the hells wrong? Anyone please... trying to get my pops truck running. The only thing I van think of is maybe a bad switch?

  2. #2
    Jr. Apprentice SkullMountainRider's Avatar
    Join Date
    Mar 2011
    Location
    British Columbia, Canada
    Posts
    28

    Default

    Yah. Probably the ignition switch. Make sure the ignition is in "lock" and drop the steering column, the switch should be on top.. I'm not sure but, you might be able to test it..

Similar Threads

  1. 96 Chevy 5.7 wont start, no spark, everything new! lol
    By mdm6713 in forum Performance & Fuel
    Replies: 5
    Last Post: 06-11-2010, 11:24 PM
  2. Stereo Controls Going Haywire
    By nstaricha in forum Audio, Video & Gadget Tech
    Replies: 4
    Last Post: 08-21-2009, 08:14 AM
  3. Wipers gone haywire-1998 Yukon
    By mateospeed in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 3
    Last Post: 04-27-2009, 08:18 AM
  4. Installing chevy remote start????????
    By CharlieP in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 12-07-2008, 07:26 PM
  5. 1994 Chevy Suburban Won't Start
    By Nazimek442 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 06-14-2008, 08:00 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •