GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Hybrid View

  1. #1

    Default 95 Yukon 350 runs awful and dies at highway operating temps

    Very inconvenient problem. I have not been able to get any codes from 95 model computer other than o2 sensor which I replaced and no help. Service engine light comes on routinely. At highway temps it suffers loss of power not unlike a choke stuck or just bad out of time. After cool off period goes back to normal running, not great but normal for this truck. Truck has 235k miles, all stock, recent tune up. Problem seems to be getting worse as originally it would fail to start on highway runs after pit stop. Now loses power and dies on the freeway!!! In Atlanta!!! Yikes!!! Runs rough, smells rich and goes dead until cools off.

    Thanks for any help!

    ---------- Post added at 04:38 PM ---------- Previous post was at 03:23 PM ----------

    It has been suggested that I possibly have a bad Ignition control module or a bad coil. I should remove the ICM and have it tested and if it is good then replace the coil. What do y'all think!!!
    Last edited by DelHenry; 03-27-2011 at 03:26 PM. Reason: icon

  2. #2

    Default

    Coolant temp sensor. 15 bucks. It's the two wire sensor in the intake by the thermostat, not the one wire sensor in the drivers side head.
    When you hear hoofbeats, look for horses not zebras.

  3. #3

    Default

    I believe I'm having this problem as well.

  4. #4

    Default

    Thanks! I will get one today. Is that a common failure when the heat builds up? What did you think re: the ICM or the coil possiblities?

Similar Threads

  1. BakFlip Customer Service Is Awful
    By sharper4 in forum Chevy Truck Accessories
    Replies: 0
    Last Post: 06-29-2010, 08:26 AM
  2. thruck runs but then dies out
    By 454 2500 burban in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 10-20-2009, 10:05 PM
  3. tranny temps
    By MoBillyAla in forum GM Powertrain
    Replies: 6
    Last Post: 07-27-2009, 09:16 PM
  4. 2004 Suburban Dies on the highway
    By jsamotis in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 09-05-2008, 09:48 PM
  5. Ice and freezing temps in Texas!
    By Steve in forum The Coffee Shop ~ Chit Chat
    Replies: 0
    Last Post: 02-18-2006, 08:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •