GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 15
  1. #1
    Sr. Apprentice
    Join Date
    Feb 2011
    Location
    North Dallas
    Posts
    51

    Question Rough Country Level Kit Now random clunk/pop passenger side

    Alright fellas I am out of Ideas with this one. Okay 2008 Chevy z71 xcab installed RC 2" leveling kit about 3 weeks ago and now have developed a random clunk/pop on the passenger side of the truck or so it seems its on that side. It can be felt in the floor board. I have checked and rechecked all the torque specs to make sure nothing has come loose. The thing is it only happens when backing up turning wheel with a little brake pressure, when pulling forward with wheel turned. I am completely stumped on this one. Doesn't do it driving down the road or stop and go traffic with turning involved. Can make it do it bouncing it while parked or rocking it side to side. Nothing appears to be in a bind, so at this point i am a bit lost on what to check. Almost thinking taking it all back apart and starting all over but thought I would come to you guys and see what your thoughts on it might be.

  2. #2

    Default

    very weird, i have the same kit and no issues
    2008 TAHOE LT, volant powercore, superchips programmer

  3. #3
    Sr. Apprentice
    Join Date
    Feb 2011
    Location
    North Dallas
    Posts
    51

    Default

    Well it was buggin me this morning so went out side for one more check and was just looking around and noticed the sway bar link and looked at the amount of thread showing from the driver to the passenger side. Driver side had about an inch of tread showing and passenger had 1.25 to 1.5. So maybe in my frustrated state of mind i ended up over tightening the passenger side putting some bing on it, not sure. So backed it off to match the driver side and we will see.

    Just out of curiosity jbjohnson92f if you get a moment would you peek at yours and see if you have more than an inch showing on the sway bar link threads.

  4. #4

    Default

    Yeah I have the same kit and the same problem it seems to come and go though. Does anyone know what it could be?
    *2010 Chevrolet 1500 LT
    *extended cab Long bed
    *Line-X bed liner
    *Rough Country 2 inch leveling kit
    *k&N Cai 63
    *Bullydog gt
    *custom A-pillar
    *17 Hoss XD
    *BF Goodrich Mud terrain KM2 285/70/17

  5. #5

    Default

    I think I read sometime ago on this site that RC had a recall on one fo there kits, they had redisigned it. I'd give them a call and see if this is the kit.

  6. #6

    Default

    i just watched an install video on youtube and it looks like its only about an inch of threading

  7. #7
    Master Mechanic clgoch187's Avatar
    Join Date
    Aug 2010
    Location
    Gettysburg, Pennsylvania, United States
    Posts
    900

    Default

    are your torsion adjusters cranked all the way? if so back em off a bit
    03 Silverado 1500
    285/75/16 BFG's
    2 Blaupunkt 10" vW1000 subs in Subthump box
    ProComp Level Lift & 3" rear blocks

  8. #8
    Sr. Apprentice
    Join Date
    Feb 2011
    Location
    North Dallas
    Posts
    51

    Default

    Well hmmm the search continues the mysterious pop/clunk. May just have to tear it down and redo everything

    ---------- Post added at 06:12 PM ---------- Previous post was at 06:10 PM ----------

    Its the full independent with coil over no torsions.

  9. #9

    Default

    I would give RC tech line a call. May save you alot of hassle.

  10. #10
    Sr. Apprentice
    Join Date
    Feb 2011
    Location
    North Dallas
    Posts
    51

    Default

    Yeah I made one more attempt at the tech line. I did end up with a pretty knowledge able guy. This is what he told me for anyone else that might be having the same issue. jack truck up go through all nuts and bolts loosen them drop truck on its on weight and re tighten everything back to specs. Pay close attention the the sway bar links as there should be only an inch of thread showing from the top of the nut to the top of link bolt. He felt the popping could have been coming from over tightened sway bar links causing a binding issue resulting the pop under various loads. As of right now time to get the tools out and got to town on everything. Maybe this will fix if not might just have to live with it or take it to the chevy house

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Rough Country Spindles/ Tuff Country A-add a Leaf? OPINONS?????
    By dgifford in forum Lifted & Offroad Suspension
    Replies: 7
    Last: 01-06-2011, 04:52 PM
  2. Replies: 1
    Last: 12-15-2010, 02:00 PM
  3. Rough country full level kit installed
    By drakeoz71 in forum Chevy Truck Accessories
    Replies: 1
    Last: 06-16-2010, 08:46 PM
  4. Tuff Country Level Lift is done!
    By 1S1K in forum Lifted & Offroad Suspension
    Replies: 20
    Last: 08-12-2009, 02:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •