GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default No Radio Illumination [Expired Topic]

    '07 Nox. I have been reasonably satisfied with the vehicle so far, minor problems and all. Just recently, upon startup the radio illumination is blank. It plays, but no clock, no info at all. The other lights, odometer, etc. are fine. It will eventually light up in 1-10 mins. Any input here before I haul it off to the dealer?

    Respectfully,
    BINGO53
    '07 Nox LT
    '99 Saturn SL1

  2. #2

    Default

    That's not normal. Could be anything from a loose display wire or something wrong with the unit itself. I wouldn't play around and would at least drive it to the dealer to get it logged as a problem, if not looked at.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

  3. #3

    Default

    Thanks for the reply Steve. I am definitely going to haul it off to the dealer. However, this morning it is doing just fine. I think I am in for some of the "unable to duplicate problem" routine At least I have a pretty good dealer, and quite a bit of warranty left.

    Respectfully,
    BINGO53

  4. #4

    Default

    Sometimes it's not a bad idea to mention it the next time you're in at the deal and ask that it be noted that you report it to them, just so it's easy to bring up if/when it starts to happen again.
    Some people call me the space cowboy ... some people don't.

    2010 Chevy Silverado Z71 Just picked it up
    2007 Chevy Colorado Just traded her in!

  5. #5

    Default

    Took it in to the dealer this week. Of course it would not duplicate itself. I left it with the dealer, they called later in the afternoon, it was fixed. Loose gound wire.

    Thank you for all your replies.

    Respectfully,
    BINGO53

Similar Threads

  1. 05 Avalanche - radio lights don't work at night [Expired Topic]
    By lakebear99 in forum Chevy Avalanche Forum (Escalade EXT)
    Replies: 0
    Last: 03-05-2009, 08:11 AM
  2. Replacing Lights In The Radio [Expired Topic]
    By udderchaos in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 08-22-2006, 09:27 AM
  3. What now [Expired Topic]
    By beastsuburban in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 05-09-2006, 08:29 PM
  4. Radio Unlock Codes [Expired Topic]
    By Dr_Zero in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 05-08-2006, 01:14 PM
  5. Too much? [Expired Topic]
    By beastsuburban in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 05-03-2006, 10:48 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •