GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Thread: Idles issues

  1. #1
    Jr. Mechanic
    Join Date
    Jul 2008
    Location
    Bluegrass Country
    Posts
    112

    Default Idles issues

    I have an 05 Duramax 2500 with a 6 spd manual trans. I'm having an idle problem, think it may be a bad injector, but I want to hear what you have to say. It will only do it once the truck is warm, but not all the time. When you come up to a stop sign and the clutch pushed in, it acts like it has a miss. The gear shifter will start shaking from side to side, the whole truck feels like your driving over a rumble strip along the highway. But it will stop if I increase the idle RPMs up to 900-1000 rpms. It will do the same thing, if I jump out of the truck to open a gate, it will start to make a noise that resembles injector clatter, but as soon as I give it a little rpm it will quit. Whats aggrivating is, I took it to the dealer to have them check it twice and I can't get it to do it while I'm there. There isn't a way to check the injectors unless I let the dealer do it or I pull them out to be sent off and tested. Any input you guys have would be appreciated. It has 149,xxx miles, fuel filter change 5k miles ago, air filter replacement 5k miles ago, and its bone stock.

  2. #2

    Default

    I would be happy to look into this for you. In order to do more research, I will need the VIN for the vehicle. Please feel free to contact me either here on the thread or via private message. I look forward to hearing from you.

    Tricia, GM Customer Service.

  3. #3

    Default

    Sounds kind of like you may have an injector harness rubbing against something... Or a harness not getting good contact all the time.... This is common on the #2 and #7 injectors.... I would closely inspect all the injector harnesses and maybe even take them apart and carefully use an ice pick to run through the individual connectors on each wire... GM's fix if it's a harness rub problem is to install a slightly longer harness on those injectors since the originals are really a little short....

    If it was my truck I'd check for rub through on the harnesses and ice pick the connectors to make sure everything is getting good contact...
    Joseph


    Airforce Veteran (7 years)


    NRA Life Member

  4. #4
    Jr. Mechanic
    Join Date
    Jul 2008
    Location
    Bluegrass Country
    Posts
    112

    Default

    I had a problem 2 yrs ago with the #2 injector harness. It took the dealer a week to isolate the problem and 7 bills later it was fixed with a longer lead on #2. The symptoms are not the same this time. The injector issue before would cause the truck to miss/hiccup at all RPMs. I'm just a little shy about taking it back to the dealer, if you know what I mean.

Similar Threads

  1. 2000 Silverado Idles Rough
    By gweano in forum Performance & Fuel
    Replies: 2
    Last: 05-17-2010, 01:58 PM
  2. 89 Burban idles rough with ETC wire connected
    By Big6ft6 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 05-14-2010, 02:17 PM
  3. 06 silverado Idles rough when cold
    By 6T7GOAT in forum GM Powertrain
    Replies: 1
    Last: 05-13-2010, 02:39 PM
  4. Idles Rough At Start-Up
    By mrcaddy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 01-11-2010, 03:46 PM
  5. idles wide open
    By T TOP TOM in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 08-17-2008, 06:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •