GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 17
  1. #1

    Default XM Radio Quit Working

    The XM radio in my 2009 Silverado quit working. It will only tune to channels 0, 1, and 247. I called XM, and they "reset" the radio, but nothing changed. XM tech support suggested taking the truck to the dealer, but the radio "works". AM/FM/CD is fine, and it still tunes and plays audio on the three XM stations it will display.

    Anybody else deal with this, and how'd you fix it?
    Kevin Singleton '09 Z71 - PA ZRT - kevindsingleton.com

  2. #2

    Default

    I would also have to recommend contacting the dealership regarding this concern. Even if this does not turn out to be some kind of issue with the unit itself, the dealership may be able to work with XM in order to resolve the concern. Please feel free to keep me updated regarding the concern. Thank you.

    Tricia, GM Customer Service.

  3. #3

    Default

    did you have the radio turned on when they tried resetting it, you can actually send a reset signal from the xm website instead of dealing with the idiot indian people that make up their customer service department. the 3 channels your getting are pretty much the sample channels that you receive without having a subscription, if something was wrong with the radio, you woulden't be receiving any channels at all.
    I didn't do it. nobody saw me do it, you can't prove anything

  4. #4

    Default

    Quote Originally Posted by bart6180 View Post
    did you have the radio turned on when they tried resetting it, you can actually send a reset signal from the xm website instead of dealing with the idiot indian people that make up their customer service department. the 3 channels your getting are pretty much the sample channels that you receive without having a subscription, if something was wrong with the radio, you woulden't be receiving any channels at all.
    I agree. If it didn't work than why are those 3 channels working? Are you making sure to allow the subscription to register? I know that I leave my radio on for like 15 minutes just to make sure that the signal has registered. Just a thought
    Dave V. -- Riverside, California
    Owner of --
    2008 Chevrolet Silverado 1500 4.8Liter V8 engine 2WD w/Kenwood Double DIN CD/DVD Player
    1971 Chevrolet Chevelle 350ci V8 engine with 500+ horsepower (Still Under Construction)

  5. #5

    Default

    Did you pay the bill?

    Make sure the radio is on while your refreshihg the signal as mentioned above.


    GMTruckClub members receive discounts off our normal rates! PM me for quotes! Check out our Films gallery - updated with over 200 Hydro Dip films!

    If it can be painted - it can be Hydro Dipped!

    Get the Gorilla!

    gorilladip.com

    sales@gorilladip.com

  6. #6

    Default

    Quote Originally Posted by sstoner911 View Post
    Did you pay the bill?

    Make sure the radio is on while your refreshihg the signal as mentioned above.
    You beat me to it sstoner!!

    ________2013 4C Rated__________


  7. #7

    Default

    Quote Originally Posted by bart6180 View Post
    did you have the radio turned on when they tried resetting it, you can actually send a reset signal from the xm website instead of dealing with the idiot indian people that make up their customer service department. the 3 channels your getting are pretty much the sample channels that you receive without having a subscription, if something was wrong with the radio, you woulden't be receiving any channels at all.
    I did what they told me to do, while I was on the phone with them. Sometimes it was on, sometimes it was off. We went through every permutation: no joy.

    I agree that it's not the unit, and I explained that to the techs. The same thing happened when my first year subscription rolled over, but they were able to "reset" it, then. This time, they don't seem to be as ...effective.

    ---------- Post added at 08:29 AM ---------- Previous post was at 08:27 AM ----------

    Quote Originally Posted by hotrodking86 View Post
    I agree. If it didn't work than why are those 3 channels working? Are you making sure to allow the subscription to register? I know that I leave my radio on for like 15 minutes just to make sure that the signal has registered. Just a thought
    It was on when they told me to turn it on, and off when they told me to turn it off. I spent a couple of hours on the phone with their technicians. I've had the subscription since 2005, from a portable unit, which I switched to the radio in the Silverado in March, '09.

    ---------- Post added at 08:29 AM ---------- Previous post was at 08:29 AM ----------

    Quote Originally Posted by sstoner911 View Post
    Did you pay the bill?

    Make sure the radio is on while your refreshihg the signal as mentioned above.
    Yeah, it's a subscription that automatically renews from my checking account. I've had the subscription since 2005.

  8. #8

    Default

    Have you checked your portable unit to see if for some silly reason the subscription reverted back to it?
    Lane - Oklahoma
    2010 Chevrorlet Silverado LT Ext Cab 2wd
    - Volant CAI, Westin Steps, WeatherTech Vent Shades, Bug Shield, and Mud Flaps, Bullet Liner, Slimline Truck Cover
    2008 Pontiac Solstice GXP

  9. #9

    Default

    Quote Originally Posted by NCN8ive View Post
    Have you checked your portable unit to see if for some silly reason the subscription reverted back to it?
    I didn't think of trying that ...because I sold it two years ago! Good idea, though!

  10. #10

    Default

    So, I just bought an '09 silverado, used of course, and at the urging of my brother decided to try out XM. I'm having the same issues everyone here is having. Reset at least four times, and still only receive channels 0 and 1. I can hear the preview well, but no other channels. Just like many of you, XM told me to take it to the dealer. Well the dealer can't get me in until monday but I have no time.

    Have any of you already been to service over this issue? If so, what is the verdict?

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. My factory remote start quit working, any ideas?
    By Stealthy GMC in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last: 01-08-2012, 12:31 AM
  2. Gauges quit working...?
    By offroadaddict in forum GM Electrical Tech
    Replies: 21
    Last: 08-25-2011, 08:01 PM
  3. 97 burb trans quit working
    By somonenew1994 in forum GM Powertrain
    Replies: 6
    Last: 08-18-2010, 07:56 PM
  4. Door lock actuator(s) quit working
    By buddy4338 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last: 07-01-2009, 06:10 AM
  5. Tripmeter quit working
    By speedbird in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 05-09-2009, 12:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •