While going through diablo's site to check for the latest update for my Trinity, I see they have a new update out... so upon asking them about it, the new Trinity update also adds support for class-2 GM vehicles! which means 1999 - 2006 vehicles that were supported by the 7192, 7193, 7198 predator are now supported by the Trinity! NICE!!

http://diablosport.com/index.php?mod...isplay&pid=151