GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5

Thread: radiator hose

  1. #1
    Jr. Mechanic pychokenny's Avatar
    Join Date
    Jun 2010
    Location
    Parkin, Arkansas, United States
    Posts
    139

    Default radiator hose

    I drive a 1994 chevy k1500 wit a 350 I replaced my upper radiator hose cause it collapsed but 2 days later the new hose collapsed now Im confused.

    I bought the truck used back n Oct. 2010.


    Do u thank it could b the heads?
    "U call we haul U bitch we unhitch.''
    "Gear grindin, Tire burnin, Diesel smoke blowin. Truck Driver."
    |^^^^^^^^^^^\||____
    | Pycho Kenny..... |||""'|""\__,_
    | _____________ l||__|__|__|)
    |(@)@)"""""""**|(@)(@)**|(@)

  2. #2
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    I'm guessing your upper rad hose is collapsing when your engine is cooling down right? This is most likely caused from a defective radiator cap or crud build up around the rad neck or cap. The cap is not letting coolant flow back into the rad & engine from the coolant recovery bottle as it cools down & is creating a vacuum instead & colapsing the hose.

    **edit.. I thought of a couple other possibilities Kenny, though they're not too likely unless the previous owner neglected the maintenance. The hose that runs from the radiator neck to the reservoir bottle could be plugged & won't let the coolant exchange back & forth, also the cap on the reservoir bottle might not be venting.
    Last edited by stephan; 05-06-2011 at 10:23 PM.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  3. #3

    Default

    Sounds right on to me to....
    1998 K1500 Ext. Cab 4.3 5spd
    Amsoil, CIA

    2007 Harley Davidson Vrod
    Amsoil, Vance & Hines 2into1, K&N Topless,
    Screamin Eagle Racetuner, StageII cams,
    Carbon fiber front fender, and a few more lil goodies:wink:

  4. #4
    Jr. Mechanic pychokenny's Avatar
    Join Date
    Jun 2010
    Location
    Parkin, Arkansas, United States
    Posts
    139

    Default

    it is collapsing when the motor is running 2 mins after i start it up

  5. #5

    Default

    Try replacing your radator cap, and thermostat there not much and it shouldn't cost more than $15-20 for both of them. Also try flushing your cooling system, there could be a block somewhere in it. Make sure that there isn't a lot of air in the system and that you have enough coolant in it too.
    1995 C1500 4.3L 2WD. JET TBI Spacer, JET stage 1 chip, 10mm Taylor custom wires, Pulstar Iridium Pulse Plugs.
    260k miles and still going strong...

Similar Threads

  1. oil pickup hose
    By cruzreyes in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 1
    Last: 11-20-2011, 10:52 PM
  2. Hose Leaking
    By sc99z71 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 02-26-2010, 01:53 PM
  3. vent hose?
    By meash20 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 05-04-2009, 08:54 AM
  4. Leak in AC discharge hose
    By MrShorty in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 10-04-2008, 02:48 PM
  5. Heater Hose
    By cliffwilson in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last: 10-13-2005, 03:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •