GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default 98 silverado 4x2 4l60e tranny

    Hi everyone!

    I really need your feedback or opinion on this.
    I have a 1998 chevy silverado with a 4l60e tranny. As of recently, the check engine light comes on. I check the code with my scanner. I have a P1870 twice? I notice that this light comes on after pulling my trailer, or getting off the highway without pulling the trailer.

    I clear the code(s) and it runs fine. I have read a lot on this code and contacted my local transmission shops. I don't trust them. They quote me $1800 to $2500 to repair this problem, as they say "your transmission is slipping, time to rebuilt it"

    help me please.

  2. #2

    Default

    It has about 80k miles on it.

  3. #3

    Default

    Welcome to the club...
    1998 K1500 Ext. Cab 4.3 5spd
    Amsoil, CIA

    2007 Harley Davidson Vrod
    Amsoil, Vance & Hines 2into1, K&N Topless,
    Screamin Eagle Racetuner, StageII cams,
    Carbon fiber front fender, and a few more lil goodies:wink:

  4. #4

    Default

    Welcome to the club. How heavy is the trailer you tow? Have you looked at your trans fluid to see if its brown or burnt smelling?

  5. #5

    Default

    The Below Link is a.....G.M. Service Bulletin.....Re-guarding Trouble Code...P1870,

    Link,
    http://www.gmtruckclub.com/forum/showthread.php?54475-LOOK-HERE!!!-Trouble-code...p1870.....for-harsh-1-2-shifts

    For the Most part......the Service Bulletin expresses the problem is with the Control Valve Body......

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  6. #6
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    *********thread moved here***********
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  7. #7

    Default

    I have checked the fluid, neither - not brown or smells burnt........ about 4500 lbs when loaded, empty around 800 lbs .... I haven't had the light turn on when pulling the trailer empty..... I was thinking the tranny was getting hot, thought about buying a transmission cooler

  8. #8

    Default

    If you don't have a trans cooler other than the one that flows through the radiator than I would add the biggest one you can fit on the truck.

  9. #9

    Default

    I bought a transmission cooler over the weekend. I read the vague instruction, can anyone help?
    Does it matter which line goes where on the cooler.
    I was a little confuse.
    What did figure out was that I was going to place the top line of the radiator transmission to the tranny cooler but then notice that fitting were too small to fit on the radiator?? Any tranny cooler recommendations or all standard?

Similar Threads

  1. Tranny ??s - 4L60E/4L80E vs 700R4
    By omnisi in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 23
    Last Post: 12-20-2012, 04:36 AM
  2. 1994, 4L60E Tranny Problems
    By daviddiaz1986 in forum GM Powertrain
    Replies: 5
    Last Post: 03-10-2011, 10:18 PM
  3. 4L60E tranny oil filter change
    By Boo in forum GM Powertrain
    Replies: 18
    Last Post: 02-17-2009, 09:30 AM
  4. 4L60E Tranny problem
    By Kcolg in forum GM Powertrain
    Replies: 3
    Last Post: 03-30-2008, 06:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •