GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 95 chevy k1500 4wd issue

    I have a 1995 chevy k1500 w/t, 5-speed with manual floor shift (4wd). I replaced the actuator on front axle (still nothing).. the front drive shaft is spinning but not locking in and spinning the front axle. I do no know where to go from here and would preferably not like to take it to the local 4x4 shop & fix it myself. HELP PLEASE!?

  2. #2

    Default

    Check your fuse panel. Make sure it's not blowing fuses. If not, then disconnect the wiring from the actuator, engage 4wd and use a test light or something to make sure there is power. If not, trace it back.

    If you can't find anything, you could do what I had to do on my Dad's K2500 Sub...Pulled the old actuator apart, ran a long bolt through it, bolted it all together, and now the hubs are locked full time.
    Jess

    1991 Suburban


Similar Threads

  1. Got an issue with my '92 K1500
    By silverlion in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 04-04-2011, 02:00 PM
  2. 97-98 k1500 dash compatable with a 95 k1500?
    By Lifted_Bowtie in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 12-11-2010, 04:51 PM
  3. Replies: 0
    Last: 07-30-2010, 07:00 PM
  4. 95 k1500 4wd issue
    By cover3 in forum GM Powertrain
    Replies: 18
    Last: 10-13-2009, 04:56 PM
  5. 97' K1500 Brake issue
    By dsquared in forum Lifted & Offroad Suspension
    Replies: 0
    Last: 07-13-2009, 07:24 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •