GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 1995 Suburban k1500 High rpms no power

    Hello all new here hope you can help.

    I picked up a 1995 K1500 5.7l 4x4 Suburban back in december its got 225k on it.

    It has just started lagging/ no power 65 mph is all it will do and is shifting rough i have to get off the gas for it to shift and its running high rpms 3k the last tune up was at 205k on 10/09 just was looking for ideals of where to start.

    Also throwing no codes
    Last edited by Drinkin380; 05-16-2011 at 02:28 PM.

  2. #2

    Default

    Doe's it have the original cat converter? If so may be plugged.

  3. #3

    Default

    I have detailed service records back to 05 and i dont see the cat being replaced at any time know any ez way to check a cat?

  4. #4
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    I believe there is some type of flow tester. also take a look at the cap and rotor. it has been going on three years since it was replaced just see how corroded it is and clean it up some if it is really bad. just another thought as well.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  5. #5

    Default

    As Mike said there is a flow tester that goes in were the O2 sensor goes. Most muffler shops have these. If its a '95 with original cat I would replace it even if thats not the problem now, I'm sure its plugged up some. Also some shops have temp. guns that reads the exhaust temp before and after cat. I believe the temp differance should be about 100 degrees.

  6. #6

    Default

    ok thanks guys i got an appointment on thursday with a muffler shiop he said he could test it for me i got the hood up now and am checking the plugs and wires while i am changing the oil

Similar Threads

  1. High RPMS on idle
    By cfoster in forum GM Powertrain
    Replies: 1
    Last Post: 04-23-2011, 02:51 PM
  2. Transmission change at high rpms
    By rks959 in forum GM Powertrain
    Replies: 3
    Last Post: 01-31-2011, 05:42 PM
  3. Bad acceleration, has had time getting into high rpms
    By Silverado1500 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 12-09-2010, 06:21 AM
  4. My truck is Idling at high RPMs
    By gt1009 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 05-30-2010, 10:17 PM
  5. Parting out 1995 k1500 suburban
    By skinut88 in forum General Classifieds
    Replies: 8
    Last Post: 01-25-2010, 11:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •