GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Hybrid View

  1. #1

    Default Need help with miss on 99 k2500-5.7L

    I have a 1999 OBS burb with 131K miles on it. I have a miss between 1500 - 2200 rpms. There is no code or SES light. I put it on a scanner and it does not show a miss. It is not in the trans, as I can get it to miss while in parkedl and rev up to 2500.
    I have replaced the following:
    tune-up (plugs/wire/cap/rotor)
    coil (2 different brands)
    fuel filter
    fuel pump
    O2 sensor
    TPS sensor
    seafoam in gas tank to clean injectors
    and swapped from the old poppet valve spider to the ungraded injector spider

    Still can't find miss.
    Any help?

    Basically stock, has flowmaster cat-back, K&n filter, and a PCM4less computer. I have even put the stock computer back in. Same problem.
    Motor still pulls strong to 5K rpm. If I am under light throttle and lite load, that is when the miss occurs. If I give it more gas, it goes away.

  2. #2

    Default

    Could be worn lifter or cam lobe too. I know thats not good...I'll shut up.



    Jamie

    2007 Ford E250(Work van) (Ya, Ya, shut up!)
    1996 GMC Sierra SLE 1500 5.7L/4L60E

  3. #3

    Default

    If you post this in the performance area then you might get some of the truck people to give their thoughts too. I got a good response to my performance questions there.

    You could also PM a moderator and ask them to move this thread.
    Current:
    2001 K1500 Suburban
    1995 K1500 Suburban

    Previous:
    1997 Venture
    1978 400 CID Blazer
    1977 400 CID K10 Truck
    1974 350 CID K20 Truck
    1979 Z28

  4. #4
    Jr. Apprentice bobby's Avatar
    Join Date
    Aug 2006
    Location
    NorCal
    Posts
    25

    Default just a thought

    Have you checked EGR , system?

  5. #5
    Jr. Mechanic
    Join Date
    Sep 2007
    Location
    Los Angeles, CA
    Posts
    116

    Default

    Have you checked your ignition module and pickup coil inside the distributor?? Also check your fuel pressure, your regulator might be bad!!
    '88 Jimmy 4X4
    5.3l L59/ 4L60E Tuned by Tad
    4" Lift 33" BFG. Custom Brush Guard, KCs, outside spare, Oil pan guard etc.

  6. #6

    Default

    Fixed it. Worn dist gear, was throwing cam sensor off (-16*)

Similar Threads

  1. Knock and Miss
    By kdr358 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 01-15-2010, 05:03 PM
  2. Low idle miss...
    By daddytech in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 01-13-2010, 06:54 PM
  3. help with miss on 99 K2500 with 5.7L
    By 99blueburb in forum Performance & Fuel
    Replies: 4
    Last: 09-24-2007, 11:09 PM
  4. miss on 99 k2500 with 5.7L
    By 99blueburb in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 07-24-2007, 08:42 PM
  5. help! engine miss
    By lrrymrtn in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 4
    Last: 02-06-2007, 12:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •