GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1
    Master Mechanic
    383man's Avatar
    Join Date
    May 2008
    Location
    Chehalis, WA
    Posts
    507

    Default transmission problem in my cousins car

    so this is a little off base, but you guys are like my family, so i hope you'll help me with a non-gm problem...lol

    so my cousin has a 1999 subaru outback with an automatic transmission. the other day he was leaving my house, backing out, put it in drive, and nothing, wouldn't go, 1st, 2nd, 3rd, or drive. it shifts fine, no grinding or sticking, reverse works fine, park, neutral, and it will go into position in drive fine, just no go juice. is this a linkage problem possibly? is there a seperate linkage for drive than for reverse? the shop he took it to said it would be 2k for labor and parts could be up to 2k and they hadn't even looked into what the problem was, just sounds insane. would love any help you guys might have, even know it's kinds blasphemy

    2009 silverado Crew Cab LTZ Z71 4X4
    6in FabTech suspension lift
    35x13R18 nitto terra grapplers
    6k and risin

    Previously owned vehicles-
    2007 silverado ext cab LT 4x4
    2001 silverado std cab 2wd
    1990 toyota pickup
    1989 Trans Am GTA
    1957 Chevy Pickup stepside

  2. #2
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    Whaaaaat's a Subaru? I haven't seen a sub for 20 years so I can't answer the linkage que but why don't you crawl under it while your cousin works the shifter & see what's what. You may be onto smth & it's a lot easier to check than spending 2 grand. Also I'm hoping you guys checked the fluid level
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  3. #3
    Master Mechanic
    383man's Avatar
    Join Date
    May 2008
    Location
    Chehalis, WA
    Posts
    507

    Default

    lol, ya that was the first thing i checked, he had it towed to a shop today while i was at work to get a quote so he's gonna have to get it towed back here prolly so we can tinker with it, i don't know much about transmissions though :(

    2009 silverado Crew Cab LTZ Z71 4X4
    6in FabTech suspension lift
    35x13R18 nitto terra grapplers
    6k and risin

    Previously owned vehicles-
    2007 silverado ext cab LT 4x4
    2001 silverado std cab 2wd
    1990 toyota pickup
    1989 Trans Am GTA
    1957 Chevy Pickup stepside

  4. #4
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    Was the fluid nice & red & clean smelling, or was it brownish colored & smell burned?
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  5. #5
    Legend
    Caddiac's Avatar
    Join Date
    May 2011
    Location
    Upstate South Carolina
    Posts
    1,994
    Blog Entries
    3

    Default

    Most likely its time for the rebuild the tranny show starring his money. Or he can turn the body around backwards on the chassis but then he can't back up....

  6. #6
    Master Mechanic
    383man's Avatar
    Join Date
    May 2008
    Location
    Chehalis, WA
    Posts
    507

    Default

    the tranny fluid was red, didn't smell burnt...

    2009 silverado Crew Cab LTZ Z71 4X4
    6in FabTech suspension lift
    35x13R18 nitto terra grapplers
    6k and risin

    Previously owned vehicles-
    2007 silverado ext cab LT 4x4
    2001 silverado std cab 2wd
    1990 toyota pickup
    1989 Trans Am GTA
    1957 Chevy Pickup stepside

Similar Threads

  1. transmission problem?
    By warsey in forum Chevy Blazer Forum (GMC Jimmy)
    Replies: 16
    Last Post: 10-29-2009, 12:22 PM
  2. Transmission Problem...
    By SwamperRider in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 09-22-2009, 08:09 AM
  3. transmission problem
    By silverado1987 in forum General Chevy & GM Tech Questions
    Replies: 7
    Last Post: 08-30-2009, 05:23 AM
  4. Transmission problem 93 Van
    By Nelly in forum GM Powertrain
    Replies: 6
    Last Post: 06-20-2009, 06:18 PM
  5. Transmission problem [Expired Topic]
    By dbledsoe in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 07-21-2006, 11:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •