GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default electrical issue

    i have a 1986 Suburban and one of the wires on one of the window switches was loose and it sparked and now i have no power to anything in the ignition. my headlights still work so it didn't kill all the power but i have no gauges, radio etc.. i checked all the fuses they are all good. any and all suggestions are welcome.

  2. #2
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,610
    Blog Entries
    1

    Default

    First I would fix the switch wire that sparked & make sure that's in order, (disconnect your negative battery cable first) then I would go back & check all your fuses on both sides with a volt meter if you have one, or with a test light if you don't.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  3. #3

    Default

    all fuses are good. the wires going from the outside of the firewall look as well so i'm guessing it's something behind the fuse box or in the ignition?? i have no idea. electrical stuff can be so difficult at times if you don't know the source of the problem. it may just be one of those things i have dig for.

Similar Threads

  1. electrical issue ?
    By okysmokey911 in forum Chevy C/K Truck Forum
    Replies: 0
    Last: 06-15-2010, 10:25 PM
  2. Trans electrical(?) issue
    By bigdogdaddy in forum GM Powertrain
    Replies: 1
    Last: 05-28-2010, 03:20 PM
  3. Electrical Power issue
    By ColonialRovers in forum General Chevy & GM Tech Questions
    Replies: 16
    Last: 10-06-2009, 09:20 PM
  4. electrical issue??
    By GReddy212 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 3
    Last: 04-04-2009, 08:50 AM
  5. Audio troubles and electrical issue
    By hailey in forum Audio, Video & Gadget Tech
    Replies: 1
    Last: 02-03-2009, 07:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •