GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 92 Sonoma SLE Vortec 4.3l V6 RWD - Turns over fine but takes forever to start.

    I replaced the starter and it seemed to startup fast for a while then went right back to 2-3 minutes of turning over before the oil gage goes up and then about another minute to get the engine started.

    Really annoying - help is greatly appreciated.

  2. #2

    Default

    No one has had this problem? Seriously!

Similar Threads

  1. 97 Suburban K1500 5.7 won't start, but turns over fine,has spark and is getting fuel.
    By boycbronco in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 8
    Last Post: 08-26-2011, 07:44 PM
  2. My 92 GMC Sonoma SLE w/Vortec 4.3l V6
    By MaxDaMonkey in forum Photo & Video Gallery
    Replies: 1
    Last Post: 06-02-2011, 01:11 PM
  3. turns but will not start
    By Jeremy.kayla in forum GM Powertrain
    Replies: 5
    Last Post: 07-19-2010, 11:05 PM
  4. Really hard start, idle around 300 rpm. Works fine all of a sudden
    By mjalstad in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 03-06-2009, 10:02 PM
  5. engine turns over, but won't start [Expired Topic]
    By whitestonian in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 11-25-2006, 03:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •