GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Transmission, I think, Problem

    I have a 2000 silverado 4x4 automatic with small v8. I've recently noticed a slight vibration with speed in excess of 30MPH and it appears as though my transmission is making a "clicking" sound when taking off. At first the clicking would go away when in either 2nd or 3rd but now does it when downshifting as well. Any help would be great...

  2. #2

    Default

    Welcome to the club. Check you front CV joints. If there worn they can click at anytime. You'll here them more when going slow because of less engine noise.
    :cool:

    2005 Chevy Silverado Z71 Crew Cab
    6" Skyjacker lift w/Edlebrock dual front remote resoviour shocks, single rear remote. Rancho skid-plate.
    17" x 9" M/T Classic Lock Wheels, 35" BFG A/T or M/T tires
    4.10 PercisionGears w/factory locker, T/A Performance rear-end cover
    Banks CAI intake, ported throttlebody, JBA coated headers, over-sized Magnaflow cats, Magnaflow cat back exhaust, Diablo tuned
    B&M aluminum deep transmission pan
    Warn brush guard w/Warn 9.5 XP winch, PIAA bulbs, Line-X bedliner, AWS Black tool chest, Extang tonneau cover
    Weather Tech floor mats
    Cover-Craft seat covers
    Dash mat cover
    Formula One window tint
    One black Lab in rear seat.
    :glasses:

  3. #3
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Also U-Joints... Especially since you mentioned a clunk when taking off.

    Also thread moved here
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  4. #4

    Default

    Sometimes the clunk taking off can be the chain in the transfer case being wore out.
    Nick- Kansas
    1994 Camaro (3.4L)
    1999 Silverado Z71 (5.3L)

  5. #5

    Default murdog94 wins

    The rear u-joint from the drive shaft to the rear axel was shot. Popped it off and the bearings were nothing but metal dust. Thanks for the help folks...

Similar Threads

  1. transmission problem?
    By warsey in forum Chevy Blazer Forum (GMC Jimmy)
    Replies: 16
    Last: 10-29-2009, 12:22 PM
  2. Transmission Problem...
    By SwamperRider in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 09-22-2009, 08:09 AM
  3. transmission problem
    By silverado1987 in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 08-30-2009, 05:23 AM
  4. Transmission problem 93 Van
    By Nelly in forum GM Powertrain
    Replies: 6
    Last: 06-20-2009, 06:18 PM
  5. Transmission problem [Expired Topic]
    By dbledsoe in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 07-21-2006, 11:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •