GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Something draining the battery.

    Hey Guys,
    I have a issue with my 2003 Yukon. While it's idling the Voltage is 14v, but when you start driving you can see the voltage drop until the engine dies. I already replaced the battery and the alternator. When I restart the engine, I can let it sit forever and it will read 14v, but when I start driving it will kill the battery again. Any Ideas?

  2. #2

    Default

    Yust becuse you already has replaced your bat and alternator dosent exclude them from being broken ,, your scenario looks like a thrue alternator problem ,, what happends with the voltage if you rev the engine standning still ? and has you checked your connections ? is the alternator HOT and finaly what happends with your voltage if you idle and starts heavy consumers ( fan , wipers , headlights and so on ?) and same scenario but rev the engine to 2000 rpm ?

    BTW how does you restart the engine after it goes down with zero on the voltage meter ??

  3. #3
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    X2 on 2 louds advice. Did you have the old alternator & battery checked before you replaced them? Assuming your new alternator is good, this sounds like a chassis or alternator ground problem. Check them & clean them. They need to be clean & shiny, no rust & no corrosion. Also make sure your alternator is 100% grounded to the engine. If your alt ground is marginal due to paint, rust or corrosion, it will charge fine at idle, but like 2Loud says as soon as you start driving it with consumers sucking the life outta the battery, the alt won't be able to keep up.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


Similar Threads

  1. BATTERY DRAINING ON MY 03' TAHOE 5.3 4x4
    By theindnman in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 04-07-2012, 09:20 AM
  2. battery draining
    By nbturbo in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 02-28-2011, 12:52 PM
  3. 1993 battery draining problem
    By 93Chevy93 in forum Chevy C/K Truck Forum
    Replies: 6
    Last Post: 06-01-2010, 11:15 AM
  4. Battery Draining
    By cmurphy84 in forum General Chevy & GM Tech Questions
    Replies: 12
    Last Post: 02-14-2010, 08:45 PM
  5. help 98 s10 battery draining low voltage
    By noahraysanders in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 1
    Last Post: 12-03-2009, 10:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •