GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7

Thread: Hey

  1. #1
    Jr. Apprentice Clunker's Avatar
    Join Date
    Jun 2011
    Location
    Central Texas
    Posts
    13

    Default Hey

    Hi folks. My name is Michael. I'm in the Austin, TX area. I've owned GM products for many years. This is the first time I've been dissatisfied. I've got a 2008 Silverado 4X4. Bought brand new off the lot. I'm at 54K miles now. Lately, I've been having transmission problems with clunking and slack in the drive train, rough shifting and slow to engage between park, drive and reverse. Has anybody else experienced this and more importantly, were you able to resolve it (how)?

    Thanks
    Michael
    Attached Thumbnails Attached Thumbnails Latest 019.jpg  
    Last edited by Clunker; 06-23-2011 at 04:12 PM.

  2. #2

    Default

    Welcome to the club, Michael.
    :cool:

    2005 Chevy Silverado Z71 Crew Cab
    6" Skyjacker lift w/Edlebrock dual front remote resoviour shocks, single rear remote. Rancho skid-plate.
    17" x 9" M/T Classic Lock Wheels, 35" BFG A/T or M/T tires
    4.10 PercisionGears w/factory locker, T/A Performance rear-end cover
    Banks CAI intake, ported throttlebody, JBA coated headers, over-sized Magnaflow cats, Magnaflow cat back exhaust, Diablo tuned
    B&M aluminum deep transmission pan
    Warn brush guard w/Warn 9.5 XP winch, PIAA bulbs, Line-X bedliner, AWS Black tool chest, Extang tonneau cover
    Weather Tech floor mats
    Cover-Craft seat covers
    Dash mat cover
    Formula One window tint
    One black Lab in rear seat.
    :glasses:

  3. #3

    Default

    Welcome to the Club!

  4. #4
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    Welcome to the club Michael. Sorry I don't have a definitive answer, just a que, Have you serviced the trans lately, fluid & filter?
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


  5. #5
    Legend
    Caddiac's Avatar
    Join Date
    May 2011
    Location
    Upstate South Carolina
    Posts
    1,998
    Blog Entries
    3

    Default

    Welcome aboard Michael! I don't have much in the way of symptoms to go by on transmissions. Mine typically fails catastrophically. I have managed to limp back to work and called a roll back the first time and to a transmission shop the second time.

  6. #6
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Welcome aboard!
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  7. #7
    Legend Bigbomber's Avatar
    Join Date
    Feb 2010
    Location
    Winnipeg,Manitoba,Canada
    Posts
    5,089

    Default

    Welcome to the site!
    [/SIGPIC]2009 Chevy Silverado LT 1500 EXT CAB 4X4 Vortec 4.8L SFI,K&N air filter,Weathertech Floor Liners ,Weathertech Stone/Bug Deflector, Line X Spray On Bedliner, TruXport Rollup Tonneau Cover, Molded Mudguards, Viper 5701 LE 2 way Security Alarm/Remote Starter, Xm Satelite Radio,BILSTEIN 5100 rear shocks,BILSTEIN 5100 front levelling shocks,READYLIFT 2" rear lift blocks,Goodyear Wrangler Territorys -265/70R 17"

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •