GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Engine Won't Stay Running

    Hello Everyone,

    I am having an issue with my 2002 Silverado 1500 Z71 5.3L truck. At random times I will go to start the motor and it acts like it wants to but then won't run. It is similar to what happens when you have to reset the security after replacing the computer, but this is random and I haven't done anything to the truck. It will run great for weeks and then won't start 2 or 3 times and thenm start just fine.

    I have had my mechanic check over all the circuits, the pump and filter and he can't find anything wrong. I am hoping that someone else has had this problem and can tell me where to look for a solution.

    Thanks.

    Steve
    2002 Silverado 1500 Z71
    White all the Way, Baby!
    5.3L w/ Spectre CIA
    129,000 Miles

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    I would start off by running your own fuel pressure test since the GM motors are designed to start after a certain PSI only. and if the Fuel Pressure Regulator is starting to go bad it will stick and not allow the pressure to build properly.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3
    Jr. Engineer hundojoe's Avatar
    Join Date
    Feb 2010
    Location
    Elk River, Minnesota
    Posts
    210

    Default

    Check all the wires and connections going to the mass air flow sensor, also try cleaning the mass air flow sensor, good luck.
    1999 Silverado Regular Cab Short Box
    Black on Black, Line-X sprayed in bed liner
    5.3 with K&N CAI, Texas Speed 220/220 cam with 112 deg LSA
    Texas Speed computer Tune
    American Racing Headers with Cats
    4.11 gears front and back, with Eaton rear posi
    Flowmaster 40series true duals
    16X8 American Racing Nitros with 305/70/16 Goodyear MTR's
    285's in the pic



    If it ain't broke...........Give me a minute!

    Im not completely useless, I can be used as a bad example...

Similar Threads

  1. Why wont my 94 chevy truck stay running???
    By ♣Cathy♣ A♣ in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 11-13-2010, 10:05 PM
  2. Suburban will not stay running
    By bublitz3 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 10-24-2009, 11:59 AM
  3. Engine Running Hot
    By johnczub in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 02-03-2009, 01:59 PM
  4. Replies: 1
    Last Post: 07-07-2008, 02:09 PM
  5. starts but won't stay running, is it the fuel pump ?
    By ministock8 in forum GM Powertrain
    Replies: 10
    Last Post: 07-31-2007, 12:27 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •