GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Someone help out an old guy will'ya.

    Son-n-law's '99 Silverado (2000 bodystyle) has a refrigerant leak. Highside service port was leaking when I began this adventure so I replaced it. Pulled VAC for a couple of hours, let it sit for 20-30 minutes, appeared to hold vac so I charged with freon and sent him on his way, thinking I dun good. Thinking I dun good, stopped short when within a couple of weeks it was/is low again. Pulled plastic cowl off top of radiator support to see cond coil. No visuals of a leak(oily spots etc...) soaped coil, no bubbles. Soaped all connections and visually checked the compressor, no oily looking spots(and who decided to put an A/C compressor down there?!? dang, double dang). Service ports don't seem to leak as don't the accumulator/dryer.

    Soo,,,I guess I'm asking where is, or is there, a common leak place on these 1999/2000 year model trucks?

    And if it is the EVAP coil as I suspect, how hard is it to get to/replace it? Doesn't appear to be simple, hoping I'm wrong.

  2. #2

    Default

    If the system is empty I would use nitrogen to try to locate the leak, if it is not try using a can of leak detector with sealer. Also I'm thinking it may be the shrader that's leaking, sice you said it held vac for 20-30 mins with the gauges connected.

  3. #3

    Default

    System is not empty, although I can empty it and use N. But I figured if I didn't get any bubbles with 100 PSI of refrigerant pressure....
    I don't get bubbles on the schraders without the hoses, so I think there are ok, plus I replaced the highside port. This afternoon I put in a can of seal conditioner, stop leak, dye stuff, against my better judgment, and charged it up.

    Is there a "most common spot" for this year model to leak?

  4. #4
    Legend
    stephan's Avatar
    Join Date
    Sep 2010
    Location
    Far West, Oregon USA,
    Posts
    8,606
    Blog Entries
    1

    Default

    I don't know if there's a common trouble spot for your year, but all the compressor shaft seals seem to suffer leakage at one time or another. Now that you've put some dye in it, hopefully you should start seeing something soon. BTW, you're right, the evaporators are a PITA to replace. Say a prayer that you find a leak somewhere else first.
    Do you have access to a sniffer that detects freon? They are good for sleuthing out the compressor seal when it hasn't started showing the "oily leak" residue yet & you can also use it on the vents inside to make sure there is a leak in the evaporator before you go to the trouble of pulling it out.
    1988 Chevy C-3500 2wd (no pic)
    350 c.i. 5.7 L Stock Block, 4 Bolt Mains
    L-31 Vortec Heads, Edelbrock Cam & Intake,
    Holley 650, Flowtech Headers, Magnaflow exh.
    Jet Trans 700R4, B&M Ratchet, 4:10 gears,
    3" susp. lift kit "shadetree"
    No rev limiter, No speed limiter lol


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •