GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default np246 transfer case problem? Or something else

    Hi Everyone, I am new to your forum and I am having a heck of a time with my wifes 2001 yukon xl 4x4. I can fix it if I can diagnose the problem. These are the symptoms I am having. The light for the gear selector on the display only lights up behind D,R,1,2 but not neutral or park. It lights up behind P for a sec when I first start the car then it goes off. I cannot get the transfer case to go into neutral, maybe because it isnt recognizing the trans. is in neutral? My front drive shaft turns when the car is in 2wd and I feel a vibration coming from the driveshaft under my feet when moving. I have replaced nsbu switch already thinking it would fix the display problem but it didnt. I have checked the tc motor and it if functional and I have removed the front drive shaft, U joints are good. The vibration went away after removing the drive shaft. I have searched for hours trying to find out if the front driveshaft should turn freely in 2wd but I cant find anything telling me for sure. One thing that is very strange is that the driveshaft can be turned with a pair of channel locks when in 2wd. It is almost as if the clutches are lightly engaged. Oh I also took the tc motor off and worked the selector by hand and it still didnt free up any better.
    Can someone tell me what im looking at here, this thing is outside my realm of knowledge.
    Thanks for your time and help with this problem.
    Sean

  2. #2

    Default

    Welcome to the club. Have you ever changed the transfer case fluid? It should be changed every 40,000 miles. It takes Auto-Trac ll fluid and you can only get it from a GM dealer. Its blue in color. Have you checked the t/c fluid level?
    :cool:

    2005 Chevy Silverado Z71 Crew Cab
    6" Skyjacker lift w/Edlebrock dual front remote resoviour shocks, single rear remote. Rancho skid-plate.
    17" x 9" M/T Classic Lock Wheels, 35" BFG A/T or M/T tires
    4.10 PercisionGears w/factory locker, T/A Performance rear-end cover
    Banks CAI intake, ported throttlebody, JBA coated headers, over-sized Magnaflow cats, Magnaflow cat back exhaust, Diablo tuned
    B&M aluminum deep transmission pan
    Warn brush guard w/Warn 9.5 XP winch, PIAA bulbs, Line-X bedliner, AWS Black tool chest, Extang tonneau cover
    Weather Tech floor mats
    Cover-Craft seat covers
    Dash mat cover
    Formula One window tint
    One black Lab in rear seat.
    :glasses:

  3. #3

    Default

    The fluid is almost new, I changed it a month or so ago. It still looks great, and I did use the gm recommended blue tc oil. I cant figure this one out. I installed the pump rub update kit a year ago and it has been great until the last few weeks. Very strange.

Similar Threads

  1. Transfer Case Problem
    By Lil_Red_Chevy in forum GM Powertrain
    Replies: 4
    Last: 03-09-2011, 10:55 PM
  2. transfer case problem
    By 09Z71 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 08-28-2010, 02:03 PM
  3. Transfer case problem, need advice
    By freightshaker in forum GM Powertrain
    Replies: 8
    Last: 03-31-2010, 01:37 PM
  4. 2003 transfer case problem?
    By Roy Lentz in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 02-10-2007, 07:05 PM
  5. transfer case problem?
    By Roy Lentz in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 02-07-2007, 09:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •