OK, first I will give you the quick rundown.1997 truck 350 2wd auto l460

I traded this truck for a couple pistols I had,,,,,so I have about 500 invested in the truck, the tow dolly and the gas dragging it home.
The guy I bought it from already RIPPED out the engine and trans and took the block to the machinist and had it honed magged and painted ready to be put back together.

THEN,,,,,he does his checking on engine kits....LOL......$$$$$$$$costing him is all he saw, and seeing that he threw away the pistons, rods, cam, crank and all the main caps because he WAS GOING TO BUY ALL NEW HIGH PERFORMANCE STUFF, NO FACTORY JUNK FOR HIS TRUCK.

Anyway, so he lost interest and I now have a nice no rust, no dents, no chipped glass and no rips in the interior, 500 dollar truck.



My little helper helping me



YEAH YEAH, I know...redneck as hell. ( but I dont have a hoist and was going to rent one but my engine was on the trailer,,,,,,)
SO MacGyvered IT!





I hopped on Craislist and found a (still in the truck engine that I can hear run and test drive before I buy) the guy wanted 700 for it, but we worked out a deal that I would give him the fresh block and 400 for his NICE running 350 vortec out of a 99 4wd tahoe with 190,000 (all highway, he traveled accross country ALOT!).

I got the complete engine, all we did was cut the main harness, the exhaust pipes, unbolt the trans, and a few lines and pulled the motor COMPLETE with EVERYTHING on it even the air box still attached! (good for me!)


So I get it back to my house and put about 400 bucks worth of all new gaskets, seals, fluids, belt, oil pump, water pump, hoses,,,all tuneup stuff too. While it is out I figure a perfect time to change all that,,right?

OK so now I have about $1300 into this

Everything was an exact bolt up except the alternator,,,I had to use the one off the truck (different plug and pulley placement).

BUT there a few thing that I can not find out where it goes. I seached my hayes book several times and traced wires but am VERY confused!

First is the hose I am holding,,,,,,,,it comes out of the side of the intake. I am guessing that is the MAP sensor....Where does that quick connect connect to?

NOW TO MY POINT FOR ALL THIS GARBLE!!!!!!!!!

This is where it is coming from.


This is where it goes to, but there is noing even CLOSE to that area to plug into..


What in the world does this hook to?


Thanks for your help,,,a couple more things and tomorrow I put ont he last of the hoses and connectors, go through and double check all my bolts and,,,try to start it.