GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Threaded View

  1. #1

    Default Engine Temperature Guage Not Working

    • 1992 Chevrolet Suburban C1500 w/5.7L
    This Suburban has seen very little miles for several years. Was seriously thinking of selling it recently, as it's had several mechanical issues creep up over the years and they have not been addressed.

    BUT one major issue with the tranmission seems to have not been a big issue at all...so now I'm having fun cleaning it up and trying to tackle some of its other problems. This is what I want to try to fix next:
    • Temp. gauge on dash stays completely at the far left/bottom.
    • On startup (when key turned to start) the guage will briefly peg out to far right, but returns to left as soon as engine starts.
    I've done the obvious things I could think of :
    • checked coolant level (Overflow reservoir was empty, so I filled it to the "cold fill" line. I only had to add a little bit to the radiator itself though, so I don't think the level was low enough to be a problem...)
    • checked fuses (Didn't notice anything blown, and all the other guages are working, so I don't think this would be it either.)
    I tired searching but did not come across this exact issue. If there is a thread out there I missed, please point me in the right direction. I did read about a sensor located near the first spark plug. I found it, and its connector and one wire seem to be intact.

    Thanks in advance for any help!!!!!
    Last edited by Royce 67/87/97; 08-04-2011 at 12:29 PM.

Similar Threads

  1. What temperature does your engine run at?
    By Z28Johnny in forum GM Powertrain
    Replies: 3
    Last Post: 11-15-2010, 06:33 PM
  2. Engine light linked to Cruise control not working? Help!! please?
    By Rhizzlebop in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 4
    Last Post: 08-16-2010, 09:20 AM
  3. Checking oil pressure when guage not working
    By cyberpine in forum Chevy C/K Truck Forum
    Replies: 7
    Last Post: 10-22-2009, 06:25 AM
  4. Coolant Temperature too low? Check Engine light..
    By gotacamaro in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 03-13-2009, 01:45 PM
  5. Temp Guage Not Working
    By BIGFOOT in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 12-31-2008, 12:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •