GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11

    Default Looking for the less obvious now

    I decided to look at the electrical like you suggested.

    But first, I checked the ditributor shaft to make sure it was tight. Someone else had a similar problem and found that the bearing on the distributor was loose. He figured that at high RPM it rand true, but at low RPM it wabbled. Mine is tight.

    I have a cracked connector going to one of the injectors. It is brittle and has been this way for quite a long time. But I thought I'd give it another look. I started the engine and ran around to wiggle the wire on that connector and it stalled. I did this again and it stalled. I started and didn't wiggle the wire, and it stalled in about the same time. So, no telling if this is the problem.

    I'm going to see what it takes to replace the injector connectors. It doesn't look simple, because they are on a wire harness that ends somewhere, I don't know where.

  2. #12
    Legend
    TRPLXL2's Avatar
    Join Date
    Jan 2009
    Location
    Norwalk, Ohio
    Posts
    3,368
    Blog Entries
    8

    Default

    You'll never be able to remove the whole injector wiring harness by itself, that is all in the main engine harness and you'll do more damage than good. I don't know where you live, but the best way would be to go to pull a part junkyard. Find a chevy truck that has the same type of injector connector, and snip that baby off as far back as you can get it. It will cost you maybe $1.00, take it home disconnect the battery cut your bad connector off and SOLDER and heatshrink the new one on. I would bet money that is your problem, a bad ground in a new vehicle can cause many people to spend endless money on parts which never were bad to begin with. I have had plenty experience in bad grounds, I even had a bad chassis ground which caused my car to idle at 3,000rpms consistent!!!!!!!!!!

    Your lucky you caught this,..............trust me.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. fuel injectors for 99- 5.7
    By gangbox1 in forum Performance & Fuel
    Replies: 0
    Last: 03-09-2011, 12:35 AM
  2. Fuel Injectors
    By Guamrock in forum Performance & Fuel
    Replies: 0
    Last: 04-11-2010, 08:08 PM
  3. Noisy Fuel Injectors??
    By mrcaddy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 03-15-2010, 12:35 PM
  4. injectors , fuel pump or other
    By cascott325 in forum GM Powertrain
    Replies: 2
    Last: 05-31-2009, 04:41 PM
  5. upgrading fuel injectors
    By dj_skidoo in forum Performance & Fuel
    Replies: 0
    Last: 02-16-2009, 05:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •