GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Exclamation A/C Blower Motor wont work on high!!!!

    Im having problems with the a/c blower motor, first i thought that it was the motor resistor or the motor relay so i replaced both of them, and that did not fix the problem so i replaced the switch in the a/c control module and to my surprise that did not fixed either so im out of options....i dont know what to do, any suggestions? It works in all other positions except for the high...

    Make: Chevrolet
    Model: 1500 Silverado
    Year: 1997

    Parts Replaced:
    Fan blower switch
    fan motor relay
    fan motor resistor....


    thank you...

  2. #2

    Default

    Have you used a voltmeter to see if you are getting power to the resistors/blowermotor when switch is in high? Broken wire?

  3. #3

    Default

    This may sound funny. But i did the same thing this week. The switch is working from off to high. Sometimes it misses high, noticed the back of my knob is cracked and it sometimes slips.

  4. #4

    Default

    Im having the same problem, the fan is not working on high. How do you solve this without replacing the control unit? i heard that the module is expensive.

  5. #5

    Default

    Can you hear the relay click when you go to high?
    When you hear hoofbeats, look for horses not zebras.

  6. #6

    Default

    In my case, i don't hear a click from the relay. Although the fan stops working on high, the a/c indicator remains lit.

  7. #7

    Default

    If the relay isn't clicking, it isn't working. Which is of course why you don't have high speed. Could be the relay, the switch, or the wiring in between. Shouldn't be too difficult to figure out with a voltmeter
    When you hear hoofbeats, look for horses not zebras.

Similar Threads

  1. 99 Tahoe - High Volume Blower Motor Available?
    By Smartin in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 11
    Last Post: 08-26-2010, 09:06 PM
  2. Blower motor acting up on "high" setting
    By alchemist1 in forum General Chevy & GM Tech Questions
    Replies: 9
    Last Post: 09-14-2009, 05:15 AM
  3. my blower for heat wont work
    By 1995z71 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 09-13-2009, 05:01 PM
  4. 03' 6.6 wont start when motor is warm
    By hondahauler in forum GM Diesel & DuraMax
    Replies: 1
    Last Post: 08-20-2009, 10:05 AM
  5. heater motor wont shut off
    By 77chevy in forum Chevy C/K Truck Forum
    Replies: 5
    Last Post: 08-14-2009, 07:03 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •