GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default New to Site, Couple of general questions about my truck.

    Acquired myself a beautiful 92 Chevrolet Silverado 1500.

    I have already changed out the brake/stop switch to fix a cruise control and brake light problem.

    No the check engine light comes on and off at random intervals. When Coded, I get a 44, Qxygen Sensor Lean Condition.

    What could cause this besides a bad sensor, how is the best way to test the sensor?

    Also, does anyone know where I can get the plastic bushings on the mirrors that hold them in place from swinging back and forth? I cannot tighten the screws up any more, but cannot locate the bushing anywhere. (haven't called dealership yet.. but will if need be)

    And lastly. The factory radio powers up, but unresponsive. Stays on station 98.1, volume at level 4, when you hit buttons (seek, clock, balance, etc) the screen will change to the mode but nothing changes. Station wont change. Volume wont change. Any suggestions short of a replacement?

    Thanks.

    Sam.

  2. #2

    Default

    Quote Originally Posted by sam-i-am75 View Post
    Acquired myself a beautiful 92 Chevrolet Silverado 1500.

    I have already changed out the brake/stop switch to fix a cruise control and brake light problem.

    No the check engine light comes on and off at random intervals. When Coded, I get a 44, Qxygen Sensor Lean Condition.

    What could cause this besides a bad sensor, how is the best way to test the sensor?

    Also, does anyone know where I can get the plastic bushings on the mirrors that hold them in place from swinging back and forth? I cannot tighten the screws up any more, but cannot locate the bushing anywhere. (haven't called dealership yet.. but will if need be)

    And lastly. The factory radio powers up, but unresponsive. Stays on station 98.1, volume at level 4, when you hit buttons (seek, clock, balance, etc) the screen will change to the mode but nothing changes. Station wont change. Volume wont change. Any suggestions short of a replacement?

    Thanks.

    Sam.
    On Trouble Code....44, some of the Possible causes include,

    1. O2 sensor defective or lead shorted (A plugged catalytic converter will render the O2 sensor defective)
    2. Lean injectors (dirty or blocked)
    3. Water in fuel
    4. Exhaust leaks upstream of O2 sensor
    5. Fuel pressure too low

    On the Plastic Bushing's for the Mirror's, some of the outlets to check are.....G.M.Parts Club.....C/R Resto and G.M.Parts Direct.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










Similar Threads

  1. Need advice on a possible "new" truck, couple questions.
    By Falcone in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 10-21-2009, 04:05 PM
  2. a couple of general audio questions...
    By dsrtne1 in forum Audio, Video & Gadget Tech
    Replies: 8
    Last: 05-02-2009, 10:08 PM
  3. New (to me) Truck, a couple questions
    By PlasticTrucks in forum Chevy C/K Truck Forum
    Replies: 2
    Last: 03-25-2009, 01:35 AM
  4. Couple questions
    By jlsparky7 in forum GM Powertrain
    Replies: 6
    Last: 01-16-2009, 11:39 PM
  5. A couple general suburban questions...
    By bartspedden in forum The Coffee Shop ~ Chit Chat
    Replies: 2
    Last: 10-25-2007, 10:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •