GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Hybrid View

  1. #1

    Default 1996 GMC Chevrolet Suburban 1500 Geneva GTS Electrical Problems

    Hi,
    I've had this 96 Suburban Geneva GTS for a few years and all of a sudden, none of the extra stuff works. Such as the headed and cooled cup holders, tv, vcr, rear radio, and sunroof. But all of the regular suburban electrical stuff works such as the powered seats, locks, windows, etc. Its just all the extra electrical stuff doesn't. I've looked at the fuse panel on the side of the dash and no blown fuses as well as the relay panel under the hood and still nothing blown or bad. I've ran out of ideas and need some help!

  2. #2

    Default

    I've never heard of a Suburban Geneva GTS before.
    It sounds like a conversion model from the description if so I'd try googling the manufacturer (Geneva I'm guessing) and if their still in buisiness see if you can get a wiring schematic from them, or maybe you can pull that up through Google too.
    When they added all the accessories they had to add in another fuse panel somewhere for power, locate that panel, since all the added electrics are out I'd be suspect not of individual fuses but the main power supply from the battery or if the added fuse panel has a master fuse or an inline fuse on the main power wire.
    I'm gonna guess these items normally only work when the ign. is on, break out your elect. test light, turn the ign. to acc. and start testing from the battery to the fuse box, along the way you should probably run across a relay too. Unless they wired all this off of the existing truck fuse panels which creates another issue.

  3. #3
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,361

    Default

    I remember those.. When I worked for Sony we built 100 for Neiman Marcus for their X-mas catalog. here it is.. http://www.motortrend.com/features/a...ban/index.html
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  4. #4

    Default

    Quote Originally Posted by Enkeiavalanche View Post
    I remember those.. When I worked for Sony we built 100 for Neiman Marcus for their X-mas catalog. here it is.. http://www.motortrend.com/features/a...ban/index.html
    So did you guys add an additional fuse block?

  5. #5
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,361

    Default

    I don't even remember but they were a pain.. because we built 100 of them we built the prototype then they had someone build the rest in Detroit. I did work on Michel J Fox's to fix a few things..

  6. #6

    Default I Figured It Out!

    Thanks for all of the replys guys. I tried to get ahold of Geneva but they went out of business around 2000. I also checked Google for a wiring diagram that i could use but still no luck. So I got curious and checked under the dash, what a wiring nightmare. At least 15 inline fuses, a viper car alarm, and a few audiovox box's that do who knows what. Even though it was a rat's nest, I continued to search onward and found a purple disconnected wire by the what I believe to be the under dash relay panel. The other end of the purple wire came from the top side of the panel with a label "NAT". The disconnected side of the wire was also by a inlet titled "NAT" so I plugged it in and BAM.. Everything started working. I'm glad I was able to fix this electrical problem without taking it to an expert but I still have another issue, I have no idea what "NAT" is. What is it? What does it do? What purpose does it serve? If you guys could answer those few questions for me I'd greatly appreciate it.

Similar Threads

  1. 1996 GMC Suburban SLE Radio/Electrical problems
    By mrjoshua in forum Audio, Video & Gadget Tech
    Replies: 4
    Last: 12-03-2010, 09:13 AM
  2. 1996 suburban 1500
    By jabo1965 in forum GM Powertrain
    Replies: 9
    Last: 10-10-2010, 11:17 AM
  3. Problems in 4WD 1996 Chevrolet Silverado
    By bradco_4 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 06-10-2009, 03:18 PM
  4. 1996 Suburban A Few Problems
    By meenkeene518 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 08-24-2008, 12:39 AM
  5. 1996 Suburban AC Problems
    By bigbob94 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 05-15-2008, 07:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •