GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default 2010 2.4 Nox Issues

    I have one w/ 16k miles, found lots of issues on edmunds.com town-hall '10 'nox forum, here's my tale of woe.....

    What started it all this evening (Sat 9pm 8/13/11), I was looking out the kitchen window & saw a bright red flashing light at the top of the dash (looked like the headlight sensor). Went out to the car & found the onstar buttons on the mirror lit up as well. Went & got the keys, started the engine & ran it thru a run/stop cycle, now the center console & steering wheel control lights won't go off either. Then the onstar started constantly beeping about 15 min latter (more on/off cycling had passed) & the radio won't come on now too. I came in to google & read forums for the issue & found a whole slew of things (ie. oil consumption) I checked & had to add almost 2 qts. This is new, as I still change my own oil & never had it use any between changes. As stated, only 16k miles, last oil chg was 12,700, barely over 3k. I had noticed the "average fuel economy" on the DIC has only been a little over 20mpg & didn't think much of it as my wife drives this 98% of the time & 95% of it is local + she can have a heavy foot. The black soot tells the story, I ran my finger thru it & it caked off on my finger. It was like (old school) driving around 3/4 choke all day soot. Calling the dealer Mon AM!

    edmunds forum link http://townhall-talk.edmunds.com/WebX/.f1e117b/1045

    '10 Silverado 1500 LS 4.8 & '10 'Nox LT

  2. #2

    Default

    Probably the best advice anyone can give you at this point for this particular issue is take it to the dealer and let them figure out whats going on.
    Sounds like you have multiple issues and I would expect them to be covered under warranty.
    If the light and radio issue is still happening try disconnecting the battery for a few minutes to reset things, I had this issue twice on my wifes 08 HHR about a year ago and it hasnt been back since resetting it. Unfortunately when you reset it you lose any codes, but the dealership wasnt able to retrieve any codes the first time it happened even though it wasnt reset.

  3. #3

    Default

    Just curious how this turned out for you.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

Similar Threads

  1. 2010 Silverado issues
    By bryco1985 in forum General Chevy & GM Tech Questions
    Replies: 13
    Last: 01-26-2011, 05:21 PM
  2. 2010 Chevy Camaro SS on Hold for Transmission Issues - Cars.com
    By ChevyFan in forum Chevy Camaro Forum
    Replies: 0
    Last: 07-15-2009, 10:20 PM
  3. Replies: 0
    Last: 05-21-2008, 01:25 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •