GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default K2500 brake woes continued.

    Ok, I was getting really frustrated with this so I took a break. Let me bring you up to speed: I have been having brake squealing problems more now. It seems to do it more when the brakes are hot/warm. (After I have used them a few times). The brakes haven't locked up for a few weeks now. They just squeal like two pieces of metal rubbing. I replaced the Lh braked shoes earlier because the axle seal went bad. I did not replace the Rh side because they looked good and showed only .030 difference. I went ahead and replaced the Rh shoes this weekend. I found the E/M brake cable was holding the shoes out a little. I lubed it up and got it to release and slid the shoes on. I adjusted the shoes so they just barely would rub when you turn the wheels. I don't use the E/M brakes. I was told not to. Anyway, I back up to park in my drive. But I dont hit the brakes hard when I stop. Sometimes I shift into nuetral and coast to a stop. By the time I go 5 -6 miles, using them in traffic, the brakes are warm/hot and start to squeal. I can hit the brakes and the noise stops. Shoes are rubbing, right? If I back off the wheel adjusters 5 or 6 clicks, the noise will go away. Then they will start squealling again after I use them 5 or 6 times. I don't know why they keep adjusting up? The adjusters are clean and loose. The star wheel is not worn down. Why is this happening? Sometimes they will squeal when I take a Lh or Rh curve. They usually squeal between 25 and 40 MPH. Above 40 I cant tell because of all the other road noises. I need help soon, because I have a camper to pull next week.

    Another quick question: When I set the preload on the rear wheel bearings. The final torque always put the keyway right in the middle of two slots. Should I go tighter or looser when I assemble the key way?

  2. #2

    Default

    Dont remember who taught me this but I was told when hitting between the keyways to back off and install the cotter pin, never over torque to put a cotter pin in.
    Have you thought about replacing the E brake adjusters and seeing if this solves the problem?
    If the brakes are adjusted where they should be the star wheel should not turn and adjust them any more, if your brakes are like the ones on my 97 Suburban there's a spring in the adjuster to keep correct tension, I'm just guessing here but could the spring be worn and allowing over adjustment of the shoes?

  3. #3
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    487

    Default

    I just hate these kinds of problems, no matter what you do ,it is still there. It almost always happens when I assume the guy before me did it correctly and I go on doing it the same way. I would start out by making sure the parts are correct for the application, are they assembled correctly (not just put back the way you found it). Something along the line of a right hand part may fit on the left side and look just fine but just won't work, think star wheel adjuster.
    I have seen where a brake hose had gone bad and acted as a check valve and not let a disc brake calliper release completely and over heat and lock up (mine). The hose looked perfect on the outside. Only advice I have is to verify that what you have done so far is correct and the start looking elsewhere for the cause.
    Best of luck , Doug



    additional thought... maybe shoes are defective, try different brand
    Last edited by dpeter; 08-20-2011 at 10:00 AM.
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  4. #4

    Default

    Yeah, that is what I thought. That is why I took both wheels completely apart. The adjuster springs are pretty new and have plenty of tension. The good news is I do have a good full brake pedal for now. Surely someone knows something I'm missing.

  5. #5

    Default

    Are you sure it's the rears making the noise? My experience is that the fronts make noise. Take them off and clean them up. Lightly lube the caliper slides with hi temp grease made for the application, and put some anti-noise goop on the pads. You may need to machine the rotors and drums, if nothing else helps.
    Good Luck and God Bless

Similar Threads

  1. K2500 brake woes
    By Indyandy in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 08-14-2011, 09:25 AM
  2. Surging (contiued...and continued, and continued)
    By bimmer84 in forum General Chevy & GM Tech Questions
    Replies: 11
    Last Post: 06-28-2011, 04:42 PM
  3. Problems removing brake rotors on truck-K2500
    By wheeler459 in forum Lifted & Offroad Suspension
    Replies: 5
    Last Post: 06-03-2011, 06:50 PM
  4. Replies: 0
    Last Post: 09-07-2010, 05:47 AM
  5. Power steering/Brake woes
    By wgwebel67 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 12-29-2008, 08:07 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •