GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11

    Default

    ok cool, thanks !!

  2. #12

    Default

    The Blue Max wires from Napa are also top shelf. If the cap & rotor are of unknown age, replace them too. AC Delco only for those, like the plugs.

    I would also do a fuel pressure test.
    When you hear hoofbeats, look for horses not zebras.

  3. #13

    Default

    I just got home, and checked the plug wire, actually there is "only" one that is kinda of too short (first pic)

    here are the plug wire, they seems to be in a good shape but as you can see, most of them are running very close to the header (only driver side here but the other side is about the same)

    oh and I checked autozone here but they dont carry those plugs, but amazon have them...go figure....






    Last edited by loic; 09-06-2011 at 06:49 PM.

  4. #14

    Default

    I know its been a couple months old but I just got arround last night and changed the plugs and wires. the plugs were ACdelco. I replaced them anyway. one was really dirty (like too rich).
    after clearing the code and changing them, I drove arround the block and the check engine light came right back......

  5. #15
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    Okay you have a rich condition bank 1 .driver side . Said one plug was dirty. Probably injector sticking open. they have poppets on them get gummed up .
    Can change the injector ... but i would probably go to the mpfi upgrade.. You have to remove plenum anyways.
    Central port what you have now .. will end up giving you more trouble. Muti port injection whole better system.
    You will thank your driving a new truck. Will fit right where cpfi is no modifications.

  6. #16

  7. #17
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    yep .. did you read the reviews

  8. #18

    Default

    Quote Originally Posted by dipstick View Post
    yep .. did you read the reviews
    just did, people really like this. how much of a pain is it to install ?

Page 2 of 2 FirstFirst 12

Similar Threads

  1. 5.7 Vortec P0300 Random Misfire
    By BajaBrad in forum Chevy C/K Truck Forum
    Replies: 1
    Last: 08-21-2011, 07:38 PM
  2. troubleshooting p0300 random/multiple cylinder missfire
    By punchdcam in forum Performance & Fuel
    Replies: 14
    Last: 05-14-2011, 12:56 PM
  3. Yes -- Another P0300, Random Misfire CEL Problem
    By KMN in forum Chevy Blazer Forum (GMC Jimmy)
    Replies: 8
    Last: 10-26-2010, 07:25 AM
  4. P0300 misfire detected need help
    By dallas65 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 11-21-2009, 12:53 AM
  5. Random misfire 97 silverado
    By 97silvy in forum GM Powertrain
    Replies: 7
    Last: 09-21-2009, 10:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •