GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 18

Hybrid View

  1. #1

    Default P0300 random misfire

    on my 99 tahoe 4wd ( about 150k miles), my engine light went on and got this code, also a couple weeks ago, it was saying bank 1 to rich..
    spark plug are only a couple months old.
    what could cause the misfire? ( before changing the plugs I also had the random misfire code show up then went away as I changed the plugs)

  2. #2

    Default

    Quote Originally Posted by loic View Post
    on my 99 tahoe 4wd ( about 150k miles), my engine light went on and got this code, also a couple weeks ago, it was saying bank 1 to rich..
    spark plug are only a couple months old.
    what could cause the misfire? ( before changing the plugs I also had the random misfire code show up then went away as I changed the plugs)
    Trouble Code...P0300.....a Random Misfire, may mean that one or more of the following has happened


    • Faulty spark plugs or wires
    • Faulty coil (pack)
    • Faulty oxygen sensor(s)
    • Faulty fuel injector(s)
    • Burned exhaust valve
    • Faulty catalytic converter(s)
    • Stuck/blocked EGR valve / passages
    • Faulty camshaft position sensor
    • Defective computer

    What Brand of Spark Plugs did you install??

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3

    Default

    I don't remember the brand, they may be bosh, ill have to look.
    I must say that I don't like your list.......
    I changed the o2 sensors a couple months ago.
    That truck has a throttle body spacer and magnaflow exaust (was like this when I bought it)

  4. #4

    Default

    Quote Originally Posted by loic View Post
    I don't remember the brand, they may be bosh, ill have to look.
    I must say that I don't like your list.......
    I changed the o2 sensors a couple months ago.
    That truck has a throttle body spacer and magnaflow exaust (was like this when I bought it)
    Regarding which Spark plugs you installed......The Vortec Engines Run And Perform Better when A/C Delco Plugs are installed, and the ones you want are the......A/C Delco Platinum Spark Plugs......with the Bosh plugs, that may be why you are getting a Random Misfire.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  5. #5

    Default

    Easy enough, ill change them and see.
    Thanks.

  6. #6

    Default

    Quote Originally Posted by loic View Post
    Easy enough, ill change them and see.
    Thanks.
    I see you have a 99"......do you know if the Spark Plug Wires are the Original ones from the Factory??.....if so I would go with a New Set of Plug Wires.......

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










Similar Threads

  1. 5.7 Vortec P0300 Random Misfire
    By BajaBrad in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 08-21-2011, 07:38 PM
  2. troubleshooting p0300 random/multiple cylinder missfire
    By punchdcam in forum Performance & Fuel
    Replies: 14
    Last Post: 05-14-2011, 12:56 PM
  3. Yes -- Another P0300, Random Misfire CEL Problem
    By KMN in forum Chevy Blazer Forum (GMC Jimmy)
    Replies: 8
    Last Post: 10-26-2010, 07:25 AM
  4. P0300 misfire detected need help
    By dallas65 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 11-21-2009, 12:53 AM
  5. Random misfire 97 silverado
    By 97silvy in forum GM Powertrain
    Replies: 7
    Last Post: 09-21-2009, 10:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •